WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Password protected pages problem (4 posts)

  1. sysopsavant
    Member
    Posted 3 years ago #

    I'm trying to set up a plan room to host a few blueprints for contractors bidding on jobs for us. I've installed WP Download Monitor to do this. I've made a page and inserted the code to display the WP Download Monitor download page, which all works fine. However, I've set this page to be password protected and that is where I have a problem. The first time I visit the page I am prompted for a password. Once entered I can access the page fine. I can then close the browser and come back hours later and access the protected page without entering a password. I've disabled all plugins and switched back to the default theme with no luck. After some experimenting, I've discovered the only way to fix this is to clear the private data in my browser. So evidently the browser is remembering the password even though I told it not to. Firefox isn't remembering it through the password manager so it much be caching a cookie instead. I would prefer a user be required to enter the password each time the page was visited or at least once the browser was closed. Any idea how to fix this?

    You can view the site at http://www.morrispaint.com
    I've set up a test page for this. Hover over the contact tab and a test room menu will appear.
    The password is: password

  2. sysopsavant
    Member
    Posted 3 years ago #

    I may have figured it out. I had to re-upload my .htaccess file and suddenly is seems be be working correctly. Let me know if that isn't the case.

  3. sysopsavant
    Member
    Posted 3 years ago #

    Still no love. Came back this morning and the same problems have returned. I also notice that when I set a page as private it does not appear to me when logged in. Basically it doesn't appear at all. This one is stumping me.

  4. sysopsavant
    Member
    Posted 3 years ago #

    Finally figured it out. I had to edit the wp-pass.php file and change the cookie settings. Looks like it is by default set to store the cookie for 10 days.

Topic Closed

This topic has been closed to new replies.

About this Topic