WordPress.org

Ready to get started?Download WordPress

Forums

Password-protected page doesn't take password - just refreshes (40 posts)

  1. tamar
    Member
    Posted 7 years ago #

    I have a password-protected page on the latest version of wordpress. For some reason, when I or my users type in the password, nothing happens. The page simply refreshes and the password box becomes blank (once again). Is my .htaccess not configured to handle this kind of request? That's my only guess at this point.

  2. tamar
    Member
    Posted 7 years ago #

    Okay, this is still bugging me as I really want to show this blog post to people...

    From reading through the archives, this bug existed in 1.x and probably has something to do with the syntax of this line in wp-pass.php:

    setcookie('wp-postpass_' . COOKIEHASH, $_POST['post_password'], time() + 864000, COOKIEPATH);

    What can I try?

    So far -
    1. I deactivated all of my plugins (yes, all).
    2. I changed the password.

    But it looks like something that may have been inherited from a previous version: http://wordpress.org/support/topic/14408?replies=5

    Am I right and can someone help?

  3. tamar
    Member
    Posted 7 years ago #

    Hey, sorry to bump, but I'm really in need for assistance here.

  4. tamar
    Member
    Posted 7 years ago #

    Bump... do the WP developers ever come by here to fix problems addressed here? I'm not gonna give up :P

  5. tamar
    Member
    Posted 7 years ago #

    I even changed hosts (for unrelated reasons) and NO LOVE.

  6. tamar
    Member
    Posted 7 years ago #

    Hello, is anyone home?

    This is still an issue for me. I changed themes, I removed all plugins, this issue is STILL there. Has nobody encountered this yet or is nobody here a programmer who is able to fix it or at least acknowledge the problem?

  7. stephensblog
    Member
    Posted 7 years ago #

    I am having the same exact issue & like you I am not finding documentation anywhere that anyone has given a resolution to this. Can someone out there please come up with something before some of us decide to start using another blogging program???

  8. tamar
    Member
    Posted 7 years ago #

    Truthfully, I don't think anyone uses it which is why nobody here can offer any suggestions on it. :(

  9. vkaryl
    Member
    Posted 7 years ago #

    Sorry, I don't think most of us who try to help out here use the passwording stuff. And as for the devs, no, they don't spend any time "helping out" here....

  10. Chris_K
    Member
    Posted 7 years ago #

    Well, I can replicate the issue when trying to password protect a Page as opposed to a Post, for what that's worth.

    Have you had a look at http://trac.wordpress.org/ to see if this is a known bug? If not, *please* be encouraged to log it there so the developers are aware of it and can fix it (no, they don't hang out here much).

  11. Chris_K
    Member
    Posted 7 years ago #

    Well, here it is: http://trac.wordpress.org/ticket/3445

    We'll see what happens.

  12. Mark Jaquith
    WordPress Lead Dev
    Posted 7 years ago #

    Works for me using the Default theme and both WP 2.0.5 and WP 2.0.6 beta 1

    One thing that could be causing this is if your Blog URL is set to something that is automatically redirected. Say that your Blog URL is http://example.com/ but http://example.com/ forwards to http://www.example.com/ In that case, the form's POST would get wiped. But you'd likely have a lot more problems than this, if that were the case.

  13. Chris_K
    Member
    Posted 7 years ago #

    I use no redirection. I'm using 2.0.5.

    Just tried with Default theme. Same thing. You're welcome to have a look at http://www.solo-technology.com/blog - try the Disclaimer page link

    [Update: I've spammed a bunch of updates over on the trac ticket]

  14. Chris_K
    Member
    Posted 7 years ago #

    After more testing and a lot more spamming of the related trac report, I've realized that this feature works fine on a new install of 2.0.5.

    Thus, I'm willing to bet it's probably a plugin induced issue.

  15. Chris_K
    Member
    Posted 7 years ago #

    tamar - are you running wp-cache plugin?

  16. tamar
    Member
    Posted 7 years ago #

    HandySolo, no I am not. It was giving me problems (on a completely different blog) and I decided I wouldn't be using it again.

    However, regarding markjaquith's mention of redirection, I have the following in the particular site's .htaccess:

    Options +FollowSymlinks
    RewriteEngine on

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    I'm not sure if that's causing it. But I definitely needed that as my wp-admin page wasn't working without it.

  17. doodly
    Member
    Posted 7 years ago #

    I'm having a similar problem - you submit the correct password, but the password prompt page just refreshes.

    I'll look at my plugins (as that seemed to be a problem above) - anyone else have any ideas?

  18. Christine
    Member
    Posted 7 years ago #

    I wrote a really long 'answer' here:
    http://wordpress.org/support/topic/73603?replies=5
    (thanks to this thread I shortened the timing on the cookie)
    but I found part of my problems were a result of blocked cookies & something with S and D's spybot.

  19. texmex657
    Member
    Posted 7 years ago #

    having same problem as described above w/ the latest released of WP. Opened ticket 4030.

    http://trac.wordpress.org/ticket/4030

  20. cardinal808
    Member
    Posted 7 years ago #

    I've foud out that when you use Apache 1.3.26 there is no problem. When you use apache2 you cannot login with your username and password.

    When i switch back to apache 1.3 there is no problem and i can login.

    Same problem can be found here: http://wordpress.org/support/topic/108414?replies=6

  21. cardinal808
    Member
    Posted 7 years ago #

    ^^^^

    Problem with the login was with the apache build. Took another build and the problem was solved... auto-magic.

  22. texmex657
    Member
    Posted 7 years ago #

    I'm not using apache however

  23. texmex657
    Member
    Posted 7 years ago #

    friendly bump

  24. AskApache
    Member
    Posted 7 years ago #

    It really doesn't sound like an htaccess issue to me.. unless it is exactly what markjaquith suggested 3 months ago.

    You may not have redirection setup, but does your host? Hosts like dreamhost and powweb and most others allow you to set whether you just want www or remove www.

    I would ask your hosting people for help, incidentally, what hosts are you guys using?

  25. texmex657
    Member
    Posted 7 years ago #

    I'm using dreamhost actually. I want to say that I tried changing the redirection settings walready but its been so long now. I will try again.

    The current setting I have it on is:

    "Both http://www.domain.com/ and http://domain.com/ work."

  26. texmex657
    Member
    Posted 7 years ago #

    How do you like the www in your URL?

    Both http://www.domain.com/ and http://domain.com/ work.

    Add "www." if somebody goes to http://domain.com/

    Remove "www." if somebody goes to http://www.domain.com/

    Tried all 3 options...no luck.

  27. elizabeths
    Member
    Posted 7 years ago #

    texmex - are you running the wp-cache plugin? I had the same problem (also on dreamhost, with WP 2.1.3) and disabling the cache fixed it for me.

  28. texmex657
    Member
    Posted 7 years ago #

    Nah, I suspected the wp-cache plugin for a while now and disabled it. I'm thinking that I might just have to reinstall wp at this point and see how it goes.

  29. poorcookie
    Member
    Posted 7 years ago #

    I am not using wp-cache and I'm still having this problem too. This is getting annoying (especially since I use a lot of password protected entries) and I'm thinking about reinstalling entirely as well... (what a pain!)

  30. Stingray454
    Member
    Posted 7 years ago #

    I had a similar issue, not sure if this is the same thing. For me it worked in Internet Explorer, but just refreshes in Firefox.

    Anyway, I finally found a solution for it that I thought I might share to help you guys. On the Options page where you enter the URL of your site I had written something like "mysite.com". I changed this to "www.mysite.com" (ie, added "www." before the address) and everything started to work.

    I also use a redirect to forward the user to my page, and it seems to work no matter if I write mysite.com or http://www.mysite.com in the browser address field, as long as the address in the Options page contains www.

    Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic