WordPress.org

Ready to get started?Download WordPress

Forums

Password Issues only when Multisite is activated (4 posts)

  1. andycosta68
    Member
    Posted 9 months ago #

    Hi. Weird (at least weird for me) problem here.
    I may have messed this up, but this is what is happening.

    When I include the code
    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );

    to allow Multisite on my WP install, I am no longer able to log in with my password. When I remove the code from my wp-config.php I can log in just fine.

    I said I may have messed this up because I had WP previously installed, and I really did not want to use the subdomain format, but the directories format. So basically I deleted my whole WP install, deleted the MySQL DB and started from scratch.

    This was probably not the most elegant way of doing this (and possibly not the right way). I just could not find the proper information anywhere last night.

    Can someone point me in the right direction to resolve this issue?
    Thank you.

  2. What happens when you log in? You said you 'can't' but what does that mean? Does login redirect? Do you get an error?

  3. andycosta68
    Member
    Posted 9 months ago #

    Thank you for the question. I should have covered that.
    When I initially add activate the Multisite option (by adding the line of code into the wp-config.php) and refresh my page, it works fine and I can see the Network Set option under Tools.

    I then go to Step 3 (in the Codex - http://codex.wordpress.org/Create_A_Network), which is Installing a Network.

    I am asked to add a few more lines of code to wp-config.php. This is how it ends up looking like (just the added lines, the rest of the file was not altered):

    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'www.andre-costa.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    /* That's all, stop editing! Happy blogging. */

    I am then asked to modify the .htaccess file, which ends up looking like this:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Once the .htaccess is modified, my WP install requires me to log in again. I type my username and the password. When I hit the Log In button, the page refreshes and the password box is empty, but there is no error message at all.

    Any ideas what I did wrong?
    Thank you!

  4. Read through all the possibilities here: http://halfelf.org/2012/multisite-login-loop/

Reply

You must log in to post.

About this Topic