WordPress.org

Ready to get started?Download WordPress

Forums

Password gone missing after upgrade (27 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    I jut upgraded to 1.2 and it changed my password. I went and tried to retrieve it but in the email sent it only said:
    Login:
    Password: b336d2
    without a log-in name.
    and when I try it with my exsisting name it doesnt work.
    I went to mysql admin and changed the b2_users data and put a new password there but that didnt help either, help me!
    what do I do now???????

  2. Nick Momrik
    Member
    Posted 10 years ago #

    have you tried "admin" for the username?

  3. phidauex
    Member
    Posted 10 years ago #

    I had this problem, and after deleting and remaking my database with no success, I ended up deleting all the cookies from my website, and then logging in with the new password. Its an odd problem, I'm not sure why it happens, but it seems to be caused by invalid leftover cookies being read by the new installation.

  4. Anonymous
    Unregistered
    Posted 10 years ago #

    yeah I've tried admin, was the second thing I tried.
    I ended up reinstalling the whole thing :-( of course I had a backup of my posts but it still sucks

  5. Mark (podz)
    Support Maven
    Posted 10 years ago #

    This is happening to me too.
    Blank space where user should be in the reminder email ...
    Just sits there and won't let me through to the admin section.

  6. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Sorted mine after much clicking.
    Opened up the wp_users table, deleted my password from there, got a new hashed password from http://bfl.rctek.com/tools/?tool=hasher
    put that into the password field, and now I am back in :)))
    Much joy.
    /me wanders off to make a backup !

  7. dparmet
    Member
    Posted 10 years ago #

    I tried that... no luck.
    No luck clearing cookies from my browser or emptying the cache.
    If someone could tell me how to empty the cookies from my website, I can try that. I'm not quite sure what that means.

  8. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Cookies are in your computer.
    In windows
    C: - docs and setting - username - Cookies folder.

  9. Anonymous
    Unregistered
    Posted 10 years ago #

    i deleted these.. no luck. still won't work for me.

  10. Anonymous
    Unregistered
    Posted 10 years ago #

    podz is the man, that shit works.
    in my db, the row was named "b2users" though.
    maybe cause i upgraded from b2.
    shrug.
    anyway, thanks x100.

  11. wbragg17
    Member
    Posted 10 years ago #

    I'm having the same problem. OK, maybe it's because I'm frustrated but I'm going to need more explicit/specific instructions to solve this problem.
    Podz says:
    Opened up the wp_users table, deleted my password from there, got a new hashed password from http://bfl.rctek.com/tools/?tool=hasher
    put that into the password field, and now I am back in :)))
    ------------------
    Ok I don't understand exactly. Where is the wp_users table? You're not talking about the users.php file in the admin folder, are you?
    I was excited because the install went w/o any hiccups, looked good, then I went to add a post saying such, and now I can't get in...
    I really need to be working on my MA thesis, not this. Any help would be appreciated. But like I said, I'm fried. So please no assumptions, please be as explicit as possible with your instructions. Thanx again.

  12. carthik
    Member
    Posted 10 years ago #

    Your blog host should provide you with phpMyadmin access to your databases for you to do this.
    Open phpMyadmin, and click on the users table in the left menu (it could be wp_users, or yourprefix_users)
    Click "Browse"
    Click on the edit button next to the admin user.
    Delete whatever is in the password field.
    Now go to http://bfl.rctek.com/tools/?tool=hasher
    enter your desired password, and copy the hash that it generates
    Paste the hash in the password field for admin
    Save the info in the database.
    Login to WordPress using "admin" and the password you used to create the hash.
    There. If any details are missing, I will be glad to fill in. :)
    Give it a shot.

  13. Mags
    Member
    Posted 10 years ago #

    2fargon, thanks from me as well. I had the same problem, followed your steps, and all is well.
    Many thanks!

  14. girlwonder
    Member
    Posted 10 years ago #

    i just followed these very implicit and EXCELLENT directions, and fixed my friend's site. THANK YOU.

  15. Bunnios
    Member
    Posted 10 years ago #

    For those who are having trouble with the ("lost your password") password retrieval process, there is a simple bug in the wp-login.php script. It's easy to fix.
    Go to the "case 'retrievepassword':" section.
    Just under the the comment:
    // redefining user_login ensures we return the right case in the email
    Replace:
    $user_login = $user_data['user_login'];
    with:
    $user_login = $user_data->user_login;
    It looks like a classic "copy-and-paste" coding error.

  16. Jenn99
    Member
    Posted 10 years ago #

    Ok, I've tried EVERYTHING that's mentioned here. removing cookies. doing the md5 hash thing. fixing the wp-login page. Nothing lets me back in.
    This is actually the second time this has happened to me. The first time, thankfully it was only a test blog, but I had to completely wipe out my database and start from scratch. Please help! I was hoping I could officially move my blog over from MT to WP this weekend, but this is making me very nervous!

  17. Jenn99
    Member
    Posted 10 years ago #

    Weird... I thought I posted an update here.
    The problem was resolved - however I wonder if I've found a bug.
    I had to change COOKIEPATH everywhere it showed up in my wp-login to "/"
    Apparently COOKIEPATH's value WASN'T my wordpress installation's directory - it was my SITE's directory.
    for example: If I have wordpress running in a directory named "mywp" (path is "/mywp") but my site is located in "mysite" (path is "/mysite") - the value of COOKIEPATH was "/mysite" - and since it was specified in that one directory - it doesn't recognize it in another directory - therefore - it wouldn't let me in. No error messages, etc. - because all the values were correct, it was just the wrong directory.
    I think COOKIEPATH needs to be set (by the application) at the root of the domain. (Which it's not doing now)

  18. sunshine
    Member
    Posted 10 years ago #

    Both cookiepath (different blog directory) and retrieve password problems were discussed here:
    http://wordpress.org/support/6/6486
    http://wordpress.org/support/6/5560
    Keep an eye on the "beta" forums, even though we aren't takling about a beta release, bugs often get posted and fixed there. :)

  19. Jenn99
    Member
    Posted 10 years ago #

    I had searched for this problem when I first ran into it - but those posts didn't come up (or it wasn't clear that a fix was posted there...) I read in one of those that the way this form works will be changing... that will be a good thing...

  20. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    You can not have WordPress and your blog in parallel directories. As it says (somewhere, perhaps we need to make it more obvious) WordPress may be in a subdirectory of your blog address, but that's it. Setting the cookie blindly to the root of the site would be a terrible security mistake as it would make the login cookies of /~user1/ available to /~user2/. We set the cookie to the site directory so edit links and everything will still work.

  21. southerngal
    Member
    Posted 10 years ago #

    Thank you 2fargon, you are a life saver. :)

  22. catsudon
    Member
    Posted 10 years ago #

    hmmm i never thought i'd have a use for this till i couldn't log on to my test blog today! thanks 2fargon!!!

  23. stip
    Member
    Posted 10 years ago #

    2fargon
    You made my day - and saved a lot of work!
    Should you ever come to Dresden / Germany: send me an email and I'll buy you a drink!

  24. Root
    Member
    Posted 10 years ago #

    @ 2 fargon: Thankyou for your life saving instructions. A model of step by step clarity, simplicity, and completely idiot proof, witness my own success. That pw encoding widget is excellent. Thanks a million.

  25. jesus_crowbar
    Member
    Posted 10 years ago #

    podz, you are a god.
    thanks so much mate

  26. Mark (podz)
    Support Maven
    Posted 10 years ago #

    See also this thread:
    Solutions: Login problems
    http://wordpress.org/support/3/9636
    @jesus_crowbar - glad it worked !

  27. illepic
    Member
    Posted 8 years ago #

    podz, I bow to you. email wouldn't produce a new password and I had to insert a hashed pwd in mysql, like you suggested. couldn't be easier :) thank you.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.