WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Group Email Subscription
Partly works, partly doesn't (8 posts)

1 star
  1. Peter vanDoorn
    Member
    Posted 1 year ago #

    Latest versions of WP and BP installed, and whilst this plugin works for the most part, Daily & Weekly Digests are broken - they get sent, but have no meaningful content.

  2. r-a-y
    Member
    Plugin Author

    Posted 1 year ago #

    Digests should be working in v3.3.

    Please let us know if this is not the case.

  3. Peter vanDoorn
    Member
    Posted 1 year ago #

    Hi. No, I'm afraid that v3.3 doesn't work - neither before the update to BP 1.6.2, nor after (I haven't updated to WP 3.5 yet though).

    All I get still is this:

    Your daily digest of group activity at Members’ Lounge
    Group Summary:
    (14 items)
    Group:
    To disable these notifications for this group click unsubscribe - change email options

    In response to my other post about this issue, I'm afraid that I wouldn't know the 1st thing about PHP breakpoints, sorry!

    Thanks

    Peter

  4. r-a-y
    Member
    Plugin Author

    Posted 1 year ago #

    Can you tell me what type of email you are viewing when you receive it?

    Is it HTML or plain-text? If it's plain-text, then I have an idea about what's wrong.

    Do digests work when you view it from the Group Email admin page?

  5. Peter vanDoorn
    Member
    Posted 1 year ago #

    Hi. I did reply to this yesterday, but for some reason my replies are not getting posted. Hopefully you will get this.

    The emails are all sent out as HTML. In fact, I can't find an option anywhere to choose the format.

    Yes, the view digest link displays a page with the complete digests waiting for all users.

    Cheers

    Peter

  6. Peter vanDoorn
    Member
    Posted 1 year ago #

    Hello again.

    Thought you might like to know that updating to WP 3.5 hasn't made any difference!

    Cheers

    Peter

  7. Peter vanDoorn
    Member
    Posted 1 year ago #

    Hi.

    I've checked in the debug log, and there are a lot of errors. I've saved what seem to be the pertinent entries in this file:

    https://www.dropbox.com/s/d6olt1se7lt138o/debug.log

    I hope this helps you sort out what's going wrong.

    Cheers

    Peter

  8. r-a-y
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I've looked into this further.

    It appears you are using ALTERNATE_WP_CRON in wp-config.php or another plugin is defining this, plesae view this thread for more info:
    http://wordpress.org/support/topic/digests-containing-empty-content-when-running-alternate_wp_cron?replies=6

    Please post follow-ups in that thread and let me know if that works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.