WordPress.org

Ready to get started?Download WordPress

Forums

Part of my old CSS doesn't work (5 posts)

  1. Syd_Lexia
    Member
    Posted 9 years ago #

    In 1.1 and 1.2, I used the following code to put a box around each comment:

    ul#commentlist li {

    border-left: solid 1px #999999;
    border-right: solid 1px #999999;
    border-top: solid 1px #999999;
    border-bottom: solid 1px #999999;
    padding-left:8px;
    padding-right:8px;
    padding-top:8px;
    padding-bottom:8px;
    margin: 20px;
    color:#333333; <---------change#1
    }

    #commentlist p {
    color:#fff; <-----------change#2
    }

    Now it doesn't work anymore. Can anyone offer a modded version that will work with 1.5?

  2. Lorelle
    Member
    Posted 9 years ago #

    Is the "commentlist" name still the same in the new theme you are using?

    the color selector changes the color of the font and not the color of anything else. If you want the color of the box to change, you change the #999999 in the box selectors above. Is this what you are having trouble with, or is the box itself not showing up? Then check to make sure the "commentlist" is the same in the theme you've chosen. It might be called something else.

  3. NuclearMoose
    Member
    Posted 9 years ago #

    Syd,
    Save yourself some typing, dude!

    ul#commentlist li {
    border: 1px solid #999;
    padding: 8px;
    margin: 20px;
    color: #333;

    this is the short version of your above CSS. Much cleaner and easier to maintain.

  4. Lorelle
    Member
    Posted 9 years ago #

    Very true, but do realize that older browsers still don't recognize the shorthand. I say, "LET THEM UPGRADE, THE BACKSLIDERS", but some people like to think of these slow folks once in a while. Nothing wrong with it, but yes, it's much easier.

  5. Lorelle
    Member
    Posted 9 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.