WordPress.org

Ready to get started?Download WordPress

Forums

Really Simple Twitter Feed Widget
[resolved] Parse Error since update (12 posts)

  1. Tom Lynch
    Member
    Posted 9 months ago #

    Your plugin doesn't work since the update today...

    Parse error: syntax error, unexpected T_STRING in ........../really_simple_twitter_widget.php on line 231

    http://wordpress.org/extend/plugins/really-simple-twitter-feed-widget/

  2. whiletrue
    Member
    Plugin Author

    Posted 9 months ago #

    Hi Tom, starting from the 2.3.1 plugin release (out today) PHP 5.3 is mandatory, because it's a requirement for the Codebird Twitter Api we use.

    If your PHP version is lower than 5.3 (and you can't update it on your hosting service), you can download and install the previous 2.3 plugin release.

    Sorry for the uncomfortable situation, we were forced to update the library due to issues for other users.

  3. scotthenning
    Member
    Posted 9 months ago #

    I am running PHP 5.3 and running into the same problem...

  4. cbitt
    Member
    Posted 9 months ago #

    I am also running 5.3 and had this error. With all due respect these things should be tested before releasing on a live product. Nearly all of my clients are instructed to install updates if they are rated for their version of wordpress.

  5. whiletrue
    Member
    Plugin Author

    Posted 9 months ago #

    Hi all,
    sorry for that, the plugin development version worked in all our test environments before releasing it.

    Anyway, a new bugfix release is out now, addressing users with multiple Codebird instances (class_exists check is now namespace safe), if unsure consider the upgrade.

    If the upgrade doesn't solve your issue, please check and post here the exact PHP version running your site pages (e.g. inserting a temporary echo phpversion(); statement inside your theme footer file) along with the entire error string.

  6. OPShots
    Member
    Posted 9 months ago #

    I have disabled the plugin for now as I was getting the same error:

    unexpected T_STRING in ........../really_simple_twitter_widget.php on line 231
    PHP version 5.2.16

  7. Alexandre
    Member
    Posted 9 months ago #

    Same error here. Broke the whole blog. Even admin. Had to restore version 2.3 of the plugin from backup.

    PHP 5.2.17.
    WordPress 3.5.2.
    Really Simple Twitter Widget 2.3.1.1.

  8. scotthenning
    Member
    Posted 9 months ago #

    2.3.1.1 works on my stack - 5.3 running with multiple instances - all good in the hood!

    Thanks :)

  9. Alexandre
    Member
    Posted 9 months ago #

    Just updated to PHP 5.3.26 and it works now.

    whiletrue, you should look into making it backwards compatible (if at all possible), however.

  10. pdlconsumption
    Member
    Posted 9 months ago #

    Yup... went into my host control panel and updated to php 5.3 and works like a charm!

  11. whiletrue
    Member
    Plugin Author

    Posted 9 months ago #

    Hi all,
    after some night hours the new 2.3.1.2 plugin release is out, adding a compatibility fix for users stuck with PHP < 5.3. Please update and confirm that it fixes the issue on your websites.

  12. fcswebsites
    Member
    Posted 9 months ago #

    @whiletrue - Thanks for the quick update to your excellent free plugin!
    Nick

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.