WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Parse error iA3 Theme (14 posts)

  1. isar21
    Member
    Posted 3 years ago #

    Hi there,
    I have bought a nice theme from iA.
    Unfortunately I always get a Parse error when I try to activate it:

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homepages/21/d85611696/htdocs/wp/wp-content/themes/iA3 1.2.1/functions.php on line 30

    The actual code on line 30 looks like this:

    public function do_setup() {
    add_menu_page('iA³', 'iA³', 'administrator', 'ia3', array('ia3_back', 'display_admin_page'));
    add_option('ia3_options', '', '', 'yes');
    }

    What is wrong there?

    Thanks a lot
    Stephan

  2. isar21
    Member
    Posted 3 years ago #

    The wrong php version caused the problem.

    Argh.

  3. Tarky7
    Member
    Posted 3 years ago #

    I have been wanting to buy this theme for a while, being a big fan of Oliver Reichenstein and his design work with Information Architects.

    However, I just upgraded the site I want to install it to version 3.1.3, (the site is hosted on BlueHost - and using the most recent version of PHP version 5.2.17 and am getting the same error:

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/churchs2/public_html/tarky7/wp-content/themes/iA3 1.2.1/functions.php on line 30

    Could the issue be the most recent version of WordPress ?

    Grrrr !

  4. isar21
    Member
    Posted 3 years ago #

    Thanks for the info, I will be extra carefull with the upgrade.
    The only solution I can think of:
    Make sure that your PHP and MYSql Versions are up to date.

  5. lxrichter
    Member
    Posted 3 years ago #

    Have you figured out what the problem is? Having no luck with getting the theme to work. Any suggestion which wordpress version works with it?

    Can´t get it to work on Bluehost.

    Please help.

  6. Tarky
    Member
    Posted 3 years ago #

    I have gotten the theme to work with 3.1.1 ~ but not with 3.1.3 ~ epic fail that. I am on BlueHost as well:

    BlueHost: the most recent version of PHP version 5.2.17

    I tried to install it on a WordPress version 3.1.3 - no luck.

    Was successful on WP vs. 3.1.2

    Good Luck, let me know if you find out any new information on this thread,

    :)

    ~ K

    iA3

  7. liadbaniel
    Member
    Posted 3 years ago #

    IA did not work for me with the previous version of wp either.. l

    unresolved.

  8. lxrichter
    Member
    Posted 3 years ago #

    Tarky,

    Thanks, but these versions don´t work for me either.

    WP 3.1.1 and PHP 5.2.17 on Bluehost.

    Giving up for now. Not having any kind of support and people having the same problems, make this theme unusable.

    Unresolved and very disappointed.

  9. Tarky
    Member
    Posted 3 years ago #

    That sucks - I wonder what these guys at iA are doing - has anyone tried to email them directly ?

  10. airbuzz
    Member
    Posted 3 years ago #

    Hi all,

    Seems like you have a php version problem. Please make sure you use the right version of PHP.
    To make sure you have a php 5 version just create a test file: eg: test.php and include

    <?php phpinfo();?>

    After checking a bit on Google it seems like Bluehost have PHP4 and PHP5 versions hosting and that it is possible to switch between them somehow.
    The error you experience is typical of old php version.

    Also check here, this guy had same problem on Bluehost
    http://girlit.net/question/construct-issue-for-php4-and-php5-maybe-an-another-reason
    Bluehost said it was 5 but it was actually still 4....

    I am happy to hear your feedback,

    Julien, iA

    FYI: theme works with 3.1.3 of WP

  11. lxrichter
    Member
    Posted 3 years ago #

    can confirm. Bluehost says it uses php5 but seems to differentiate in reality. Changing it in php config to "handle all by php5" does the trick.

    Thanks Julian

  12. airbuzz
    Member
    Posted 3 years ago #

    Good!
    Very strange that Bluehost is doing this way,
    please Tarky and Liadbaniel, let me know if you are ok as well now.

  13. Tarky
    Member
    Posted 3 years ago #

    Hi airbuzz, Thanks for following up - I am also Tarky7, but the wacky WP forums have decided that I no longer exist - lol

    I called BlueHost today and they went through and fixed the glitch with PHP on the 3 accounts I own with them. My clients on the other hand, many of them with BlueHost are still up in the air.

    Here is the story I got with BlueHost which might help others:

    Basically, on the older server clusters (my accounts have been with them for 4 years) they have to manually go and make the change. All it took was a quick phone call to BlueHost tech support and they were able to change this in the 3 accounts in less then 30 mins.

    They seemed to have gotten the heads up about this situation, as the tech guy I spoke with was already alerted to the glitch in the PHP upgrade path.

    Thanks so much guys, I think I am in the clear, even though I only wanted to use the theme for one site: http://seo413.com/

    I can go ahead now and work on the site further.

    Cheerio !

    ~ Kit ~ aka Tarky7

  14. airbuzz
    Member
    Posted 3 years ago #

    Hi Tarky,

    you are welcome.
    Perfect, happy to see that fixed it :)
    Strange thing is that i read myself that all accounts are supposed to be PHP5.

    Liadbaniel, is it all right for you now ?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags