WordPress.org

Ready to get started?Download WordPress

Forums

Parse Error after Upgrade (42 posts)

  1. nonko_web
    Member
    Posted 5 years ago #

    I just upgraded my WordPress to 2.6.5 and now I get the following error:

    Parse error: syntax error, unexpected T_STRING in /home4/svenlerc/public_html/nonkonformist/wp-blog-header.php on line 5

    The first lines of that file look like this:

    <?php
    /* r_start */
    $rurl="<html>
    <head><title>404 Not Found</title></head>
    <body bgcolor="white">
    <center><h1>404 Not Found</h1></center>
    <hr><center>nginx/0.5.37</center>

  2. aba_
    Member
    Posted 5 years ago #

    remove the " before and after white.

    the code in wp-blog-header.php is ... aehm. i dont know what it is for. it calls a server in china (http://218.59.175.89/feed/update.txt). any idea anyone?

  3. LoLyfe
    Member
    Posted 5 years ago #

    I've got the same problem ... I'm pretty stuck...
    " Parse error: syntax error, unexpected T_STRING in /homepages/34/d85120700/htdocs/wp-blog-header.php on line 5 "
    For some reason I am unable to edit/delete this file on my server.

  4. blogbasti
    Member
    Posted 5 years ago #

    You can't edit the files, because you lost the write-permission on top folder of you installation and your file wp-blog-header.php has rights 555 :(

    Which version of wordpress do you have?

  5. blogbasti
    Member
    Posted 5 years ago #

    The cause for this problem is a security hole in wp .... currently i am looking for it.

  6. Chris_K
    Member
    Posted 5 years ago #

    More importantly, where did you get it from?
    The wp-blog-header.php file shouldn't not have anything what you showed and certainly shouldn't be linking to china!

  7. Herr Morris
    Member
    Posted 5 years ago #

    We have the same problem in this thread:
    http://wordpress.org/support/topic/220481

  8. David Z
    Member
    Posted 5 years ago #

    As of this morning, I'm getting a similar error:

    Parse error: syntax error, unexpected T_STRING in /home/nothirds/public_html/wp/wp-blog-header.php on line 5

    Although still able to access the dashboard/admin features. Talking to the guy who manages my site, he says the Header.php is "full of advertising shit".

    I have not recently made any manual changes to my template, or installed new plugins.

  9. Chris_K
    Member
    Posted 5 years ago #

    What version of WordPress are you running, David Z?

  10. blogbasti
    Member
    Posted 5 years ago #

    @HandySolo: That's correct!

    I found the following changed files in two different version of WP:

    # WP 2.1.2
    # WP 2.0.4

    index.php
    wp-blog-header.php
    xmlrpc.php
    wp-includes/wp-db.php
    wp-includes/default-filters.php
    wp-admin/index.php
    wp-admin/admin.php

  11. David Z
    Member
    Posted 5 years ago #

    2.6.3

  12. David Z
    Member
    Posted 5 years ago #

    Or might be whatever version prior - 2.6.1, not positive.

  13. Chris_K
    Member
    Posted 5 years ago #

    Sounds like you've been hacked. Would strongly suggest you start by replacing all your WordPress files via an upgrade to 2.6.5.

  14. David Z
    Member
    Posted 5 years ago #

    working on that, unable to edit/delete files in the wp directory.

  15. Herr Morris
    Member
    Posted 5 years ago #

    HandySolo, did you look at the first post adressing this problem here:

    I just upgraded my WordPress to 2.6.5 and now I get the following error:

    The 2.6.5, dosen't seem to help?

  16. aba_
    Member
    Posted 5 years ago #

    @davidz.
    can you change the permission of your wp-directory?

    it might be this (in 2.6.5 fixed) bug http://trac.wordpress.org/ticket/8291

  17. Chris_K
    Member
    Posted 5 years ago #

    OK. For Herr Morris then, starting at the top.

    @nonko_web: Where did you get the WordPress upgrade from? You definitely don't have the same version that I got from here. You've been compromised. Would suggest redoing the upgrade with fresh files from here at wordpress.org

    Regarding @aba_ first post in thread: that's not the answer. The file has bad content all around. (but it looks like you've got the answer later on in thread)

    @LoLyfe: Same question and advice as given to nonko_web.

    @David_Z issue wasn't upgrade since he was running older version.

  18. blogbasti
    Member
    Posted 5 years ago #

    @Herr Morris: I think the wp of nonko_web was already hacked before, because 2.6.5 seems to contain the solution.

    http://trac.wordpress.org/ticket/8291

    http://westi.wordpress.com/2008/11/25/wordpress-265-in-detail/

  19. Herr Morris
    Member
    Posted 5 years ago #

    OK. Thanks. So how do I go about fixing this without loosing any information or layout?

    I haven't done the installation myself, it's via an automatic thing at my host - but I do have FTP access with all rights...

  20. aba_
    Member
    Posted 5 years ago #

    @nonko_web.
    maybe you have an older version - it seems to be 2.6.1 (i just had a look at the readme.html on your webserver).

  21. aba_
    Member
    Posted 5 years ago #

    @herr morris.
    http://wordpress.org/download/
    theres a readme.html inside - for fresh installation and for upgrade. (or http://blog.wordpress-deutschland.org/2008/11/25/wordpress-265-veroeffentlicht.html for german...)

  22. jackfussell
    Member
    Posted 5 years ago #

    I think I'm having the same issues...
    http://www.travelingtribe.net 2.1.2 parse error
    http://www.camelcrossing.net same parse error...upgraded to 2.6.5....still have the parse error

    Any ideas????

  23. aba_
    Member
    Posted 5 years ago #

    @jackfussell
    download and install 2.6.5 (http://wordpress.org/download/)

    (www.camelcrossing.net seems to be 2.6.1 not 2.6.5 => http://www.camelcrossing.net/readme.html)

  24. Herr Morris
    Member
    Posted 5 years ago #

    I have now installed a 2.6.1 at another url, and I will upgrade that, and then move it to the old blogg..

    BUT my problem is that I can't import the XML file of all my bloggposts into the new blogg (it says max a 2MB, but my XML file is 11MB of my post (i checked). I tried to import it, but when the file is "uploaded" I get asked:

    "Are you sure you want to do this?
    Please try again."

    ??

  25. LoLyfe
    Member
    Posted 5 years ago #

    @HandySolo
    I used the Automatic Upgrade plugin to upgrade to 2.6.5
    I've got my hosts looking at this too, they can't figure out why all my permissions have gone awry. Even if you change the permissions you can't edit or delete the files.

  26. jackfussell
    Member
    Posted 5 years ago #

    i upgraded http://www.camelcrossing.net to 2.6.5 and have the same error

  27. aba_
    Member
    Posted 5 years ago #

    @jackfussel.
    your readme (http://www.camelcrossing.net/readme.html) says, its not 2.6.5, its 2.6.1...?

  28. Chris_K
    Member
    Posted 5 years ago #

    @LoLyfe - in looking at the code in the hacked file, I notice it mucks about with permissions. Presumably, your host will be able to get those squared away.

    @aba_ - I don't think we can rely on the readme.html to tell the version. It doesn't appear to have been updated with the release.

  29. jackfussell
    Member
    Posted 5 years ago #

    i know...i just "upgraded" on bluehost and yet nothing is changing
    bluehost acknowledges an issue with wp and will shut down allinfected sites in a week

  30. Chris_K
    Member
    Posted 5 years ago #

    @jackfussel - are you able to delete the bad wp-blog-header.php file? If so, delete it from your site and re-upload it from the zip you got from here.

Topic Closed

This topic has been closed to new replies.

About this Topic