WordPress.org

Ready to get started?Download WordPress

Forums

Comments Evolved for WordPress
[resolved] Parse Error? (11 posts)

  1. simbeckhampson
    Member
    Posted 1 year ago #

    Getting this error on the new update 1.2.0...?

    Parse error: syntax error, unexpected T_FUNCTION in /home/content/78/7130378/html/wp-content/plugins/gplus-comments/gplus-comments.php on line 45

    http://wordpress.org/extend/plugins/gplus-comments/

  2. Brandon Holtsclaw
    Member
    Plugin Author

    Posted 1 year ago #

    This means you are using a version of php older than 5.3 , php version 5.3 came out in July 2009 ( almost 4 years ago ) you should update to a newer version as 5.2 is no longer supported by php.net thus isnt secure.

  3. simbeckhampson
    Member
    Posted 1 year ago #

    Thanks Brandon. How do I update the version of PHP?

  4. Brandon Holtsclaw
    Member
    Plugin Author

    Posted 1 year ago #

    It really depends on your hosting environment ... do you run your own server or vps or do you rent from someone like http://www.wpengine.com ( btw I highly recommend, those guys over there rock! ) ?

  5. simbeckhampson
    Member
    Posted 1 year ago #

    I'm with Godaddy... I'll give them a shout. Appreciate the quick response... excellent plugin, btw :)

  6. Brandon Holtsclaw
    Member
    Plugin Author

    Posted 1 year ago #

    no problem, if you have any problems with them let me know or if not quite sure on the instructions they give feel free to ping me via email me@brandonholtsclaw.com and i'll help ya get it straight ( hopefully with very little friction )

  7. simbeckhampson
    Member
    Posted 1 year ago #

    muchas gracias :)

  8. Martin
    Member
    Posted 1 year ago #

    Being a bleeding edge kinda guy, I tried it on my main niche site and got the same error. I thought I'd enabled php 5.3 but it must have been removed on my .htaccess file.

    Your hosting company might already have it installed and adding the following lines give it to you.

    # Use PHP 5.3
    AddHandler application/x-httpd-php53 .php

    Worked for me anyway.

  9. simbeckhampson
    Member
    Posted 1 year ago #

    Super Martin! I'm just in the queue with GoDaddy Support so will mention that, hope to be up and running shortly :)

  10. Brandon Holtsclaw
    Member
    Plugin Author

    Posted 1 year ago #

    Rockin , thanks for that , I'll add it to the FAQ ... I'm also adding in a more senseable error message now too

  11. Martin
    Member
    Posted 1 year ago #

    I'm with Hostgator myself.
    If you've got FTP access to the .htaccess file, you can try it while you wait. Worked for me in 2 seconds :)
    Godaddy might be different to the access though

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.