WordPress.org

Ready to get started?Download WordPress

Forums

Parse Error (5 posts)

  1. jbessen
    Member
    Posted 8 years ago #

    I have been running 1.5.1 fine for several months, when all of a sudden anything I try to do gives me:

    Parse error: parse error, unexpected T_STRING, expecting ',' or ';' in /home/public_html/WordPress/wp-includes/wp-db.php on line 352

    Not sure what to do. I can't upgrade to 1.5.2 because I can't even access the Admin functions to deactivate plugins, etc.

  2. davidhouse
    Member
    Posted 8 years ago #

    You don't need to deactivate plugins to upgrade, that's just a recommendation. Upgrade to either 1.5.2, or 2.0 (just released :)) by following the upgrade instructions at http://codex.wordpress.org/Upgrading_WordPress. Any more problems, just explain them here.

  3. schestowitz
    Member
    Posted 8 years ago #

    I thought the changes between 1.5.1 and 1.5.2 are so minor as to be negligible. There is just a security fix, which is unrelated to wp-db.php. Hopefully this will fix the error nonetheless. With better security, it might be a case of hitting two birds with one stone. Go for 2.0 just to make it worthwhile. Back up all data first.

  4. davidhouse
    Member
    Posted 8 years ago #

    No, 1.5.2 was a bug fixing release, so it's likely to fix the problem. 1.5.1.1 and 1.5.1.2 were the security-fix releases.

  5. schestowitz
    Member
    Posted 8 years ago #

    Ahh... you're right. Sorry if I led to any confusion.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags