WordPress.org

Ready to get started?Download WordPress

Forums

Paragraph tag dissappearing upon save or code view change (42 posts)

  1. bdcinternational
    Member
    Posted 6 years ago #

    When I switch between the "Visual" & "Code" view in WP or when I save a post, some of the formatting I have applied in the visual editor isn't transferring (specifically the <p> tag).

    Let me clarify: <em> & <strong> tags DO transfer between views. <p> tag does not.

    For example, I am unable to hit the "enter" key two or three times between paragraphs because these paragraph (<p>) tags either aren't being generated in WP or they aren't present when I move between views. Therefore, when I save the page, these inserted unpopulated paragraph tags are lost.

    Another example: I can take a paragraph, designate it as "paragraph" under the formatting drop-down, and immediately see a change in the way the text is formatted in the "Visual" editor. When I switch to the "Code" editor to verify that the corresponding <p> code has been created, the <p> tags aren't present. These <p> tags disappear whether I am switching views or actually saving the post.

    I have moved between WP 2.2. & 2.3.1 to no avail on this particular site. Furthermore, I have run WP on several other sites & not had this problem.

    Thoughts? Is this possibly some sort of server-related issue that I am unaware of?

    Any advice would be very much appreciated!

  2. mbprouser
    Member
    Posted 6 years ago #

    I am suffering from exactly the same problem! Its very frustrating I have to say. The only thing that works is manually adding in <p> tags. As far as I am aware, this is a standard installation and I am modifying the Classic theme. The only plugin I have added is a search plugin which allows you to add a title to the widget.

    Any ideas?? Is there somthing I am missing somewhere?

  3. jetlag26
    Member
    Posted 6 years ago #

    I have exactly the same problem! I have 4 WordPress sites and I just created a new one that uses 2.3.1 and this problem occurred.

    I was about to upgrade my other 2.0 sites to 2.3, but will not until this is resolved.

  4. macinfo
    Member
    Posted 6 years ago #

    Same problem here!

  5. tehphil
    Member
    Posted 6 years ago #

    Same problem here...I'm using Safari 3.0.4 if that makes any difference.

  6. tehphil
    Member
    Posted 6 years ago #

    I just tested with FireFox, I think Safari might be the culprit here...

  7. barrald1213
    Member
    Posted 6 years ago #

    i've tried with both safari and firefox, to no avail. There seems to be a lot of people with this issue, going back months in the forums, and no response or support from WordPress. Very disappointing.

  8. sparkybarkalot
    Member
    Posted 6 years ago #

    I've been having the same problem. This is a huge problem, and a real showstopper for my use of WordPress, since I can't very well hand off a website to a client which they can't update. <p> tags are disappearing when inside of a div. I put them back in when in code view, and they just get deleted again. Please, someone? Anyone?

  9. sparkybarkalot
    Member
    Posted 6 years ago #

    Addendum to my last post: this is happening on Pages. Can't say whether it's happening on Posts or not.

  10. barrald1213
    Member
    Posted 6 years ago #

    It is definitely happening on posts. I just launched a new website for my current client, and this is a serious problem because this site is viewed by thousands a day during certain times of the year (aoproductions.net) and the people using it have no code knowledge so even if I disabled visual view and figured out a code hack they couldn't be expected to manually insert <p> tags.

    IF ANYONE AT WORDPRESS IS LISTENING, THIS IS A SERIOUS PROBLEM AND WE REALLY NEED THIS FIXED. Whatever algorithm is disabling <p> tags please disable it or let us know how.

  11. sparkybarkalot
    Member
    Posted 6 years ago #

    OK, I just did a test in a Post. Same issue there. Here is an example:

    <div class="test">
    <p>one</p>
    <p>two</p>
    <p>three</p>
    </div>

    If I put that in code view, then save and flip between visual and code view, each time I flip back to code view it's deleted another set of <p> and </p> tags. So after 3 or four flips between visual and code view, here is what I end up with in code view:

    <div class="test">onetwothree</div>

    Can anyone help me out here?

  12. barrald1213
    Member
    Posted 6 years ago #

    I am having an exactly identical issue sparkybarkalot. I have been searching for almost a week for a fix for this and I cannot find any. I've checked every forum, every thread, every everything and there is no apparent fix. If you come across one, please post here (I have this thread on RSS in case anything comes up) but other than that I have mostly given up, and just hope that WordPress itself can fix it.

    Individual bloggers should not have to deal with or try to fix a basic issue like this. Adding functionality is fine, I'm willing to spend time doing that, but not restoring functionality.

  13. sparkybarkalot
    Member
    Posted 6 years ago #

    After a few days of trying to get make this work, I gave up and then found the FCKEditor plugin which, after a few preliminary tests, seems to work just fine and doesn't exhibit the same problems as WP's default visual/code view. You can find it here: http://wordpress.org/support/topic/142936?replies=11#post-660065 or here: http://wordpress.org/extend/plugins/deans-fckeditor-for-wordpress-plugin/

    Obviously this is no solution, but just a workaround until someone on the WP team can sort this one out.

  14. paul7362
    Member
    Posted 6 years ago #

    I had the same problem and it's also a new blog, so I'm not sure if that has anything to do with it. I did try the FCKEditor, but it had no effect. (although I like it).

  15. JoyrexJ9
    Member
    Posted 6 years ago #

    Has this been fixed in 2.3.2??

    This makes the visual editor totally useless in fact I can't believe more people are not jumping up and down about this!!

    This is a serious bug as far as I'm concerned

  16. meetnet21
    Member
    Posted 6 years ago #

  17. sacredpath
    Member
    Posted 6 years ago #

    It's still a problem in 2.3.2.

    It's not entirely wordpress, the main problem is with TinyMCE, the editor wordpress is using. Safari compatibility is still listed as "experimental" by TinyMCE. They appear to be working on Safari 3 compatibility though from the looks of the dev logs for TinyMCE 3, but who knows when that will be out.

    I've switched to fckeditor and am having no issues in Safari 3.0.4 and Firefox has always worked fine for me on Mac's with wordpress.

    The thing is though I use the online editor only occasionally and use the offline blog editor, Ecto the majority of the time. Ecto has a quirk or two, but I've learned to work around them.

  18. growbabygreen
    Member
    Posted 6 years ago #

    So what if I don't have a mac or use Safari and I am still having this problem? I am using Avant Browser, which is somehow interconnected with IE.

  19. standerd
    Member
    Posted 6 years ago #

    We don't have a solution, but are experiencing the same problems and are very tired of it.
    Any info at all would be nice at this point.

    http://standerdslides.com

  20. circuitor
    Member
    Posted 6 years ago #

    I was having this very frustrating problem repeatedly in Safari, but switched over to Firefox and everything seems to be working fine. (WP 2.3.2)

  21. sacredpath
    Member
    Posted 6 years ago #

    The editor seems to be wacky right now and I have no idea why. People with IE7 and FF on XP and Vista are seeing the problem, as are some on FF on the Mac.

    Since I'm using an offline blog editor, I don't experience those issues anymore (unless having to edit or write a page).

    Windows Live Writer: Windows (free)
    BlogDesk: Windows (free)
    Ecto: Windows and Mac (reasonable cost)
    Qumana: Windows and Mac (free)
    MarsEdit: Windows and Mac (reasonable cost)
    Scribefire plugin for Firefox: Windows and Mac (free)

  22. growbabygreen
    Member
    Posted 6 years ago #

    I tried to install BlogDesk and it wouldn't run, then I installed Qumana, but the edits I make to images (border, spacing) don't show up on my blog. I wish wordpress would just work properly. I've spent 2 days now just figuring out how to format my blog in a pleasing way and I have yet to find a solution.

  23. growbabygreen
    Member
    Posted 6 years ago #

    I also installed Dean's FCKEditor and am very pleased. So far my returns and paragraphs are looking right. Thank god.
    http://wordpress.org/extend/plugins/deans-fckeditor-for-wordpress-plugin/

  24. elasdbark
    Member
    Posted 6 years ago #

    Its not just using return in visual mode. I can't add a lot in code mode. A whole lot of my HTML doesn't even show up upon saving
    tags, <div> tags, and more. Its getting really frustrating. (Mac Firefox user)

  25. MPA
    Member
    Posted 6 years ago #

    I just started a site using WP 2.3.2 and have been encountering the same problem. I thought I was doing something wrong, until I read about "change permissions" and tried to do just that in the "themes" directory. It did not work.

    The semi-solution that I have been applying is to use the RIGHT BLOCK QUOTE. In the visual field, before I save, I write as I normally would with the paragraphs in place. Then, I block quote each paragraph. This technique creates paragraphs, but you sacrifice a little writing space to the left margin.

    Also, to maintain spacing in between paragraphs, I have to also apply RIGHT BLOCK QUOTE.

    This work around is a tedious work-around, but my only option. Now that I know about FCKEdit, I'll try this plugin. Thanks for posting it.

  26. MPA
    Member
    Posted 6 years ago #

    Sorry, correction:

    I used the RIGHT INDENT tag function.

  27. snyderjoe
    Member
    Posted 6 years ago #

    I think I have the same problem with safari. But it works in firefox. Nevertheless I would appreciate working with my preferred browser. Thanks!

  28. baruch60610
    Member
    Posted 6 years ago #

    So far this problem continues. It isn't altogether consistent, either, so I can't even isolate the problem.

    I actually removed WordPress from one of my Websites and reverted to the old, static pages because I absolutely couldn't get simple formatting like correct line breaks to appear after saving the text. The problem was persistent, but unpredictable. On one page, after probably 30 minutes, I managed to get my line break. On another page, after an hour, I couldn't do it.

    This is a real deal-killer for a lot of people. If you can't format your pages, what good is WordPress? I don't know that other CMS programs do any better, but certainly inconsistent, unpredictable line breaking isn't acceptable.

    I don't see any WordPress people responding to this issue, either. Even a brief "We're working on it", or "Hey, it's the *browser*, stupid" would be helpful.

  29. treehugga
    Member
    Posted 6 years ago #

    Yeah it is naff that WP are not saying anything but for what it's worth, posting with firefox instead of Safari works for me now :-)

  30. Seanmyr
    Member
    Posted 6 years ago #

    I'm having this problem too. I'm running WP 2.3.2 and I use FireFox on Windows Vista. Another extremely annoying problem I am running into with the default editor has to do with forms.

    I do wordpress installs for another company and most of the sites I set up have two different forms, one is a general "contact us" type form and the other is a form for making an appointment. Anyway, everytime I go into the editor to edit one of the form pages, the editor cuts off the "send" and "clear" buttons of the form. Every time I edit the form pages I have to add back in these buttons otherwise when I save my edits the forms will not be able to be submitted because there are no buttons.

    I haven't tried the FCKEditor plugin yet and I think I will try that and see if that at least fixes the form problem. It would be nice if the WP people could come up with a fix for this though.

Topic Closed

This topic has been closed to new replies.

About this Topic