WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Pair.com and domain name not appearing in address bar of browser (10 posts)

  1. winefornewbies
    Member
    Posted 7 years ago #

    Good day --

    I'm hosting a blog with WordPress at pair.com. For some bizarre reason, if a person clicks on permalinks or separate pages hosted by the blog, the URL in the address bar of the browser is www45.pair.com/username/wordpress/yaddayaddayadda rather than blogsite.net/yaddayaddayadda.

    I inquired of pair.com's support folks, and they think it's something in WordPress. I searched the forums but didn't find anyone else who had encountered this issue.

    I feel like it must be something simple that I'm missing, and I'll probably feel like a fool when I figure it out (hopefully with some assistance), but I'm just not seeing it.

    Any help that anyone can offer will be greatly appreciated, and I offer sincere thanks in advance.

    Bill W.

  2. drmike
    Member
    Posted 7 years ago #

    Dang, that is strange. Is this a recent install and/or some sort of automated install? Even does it for the hard coded links like Register in the Meta in the right sidebar

    First thing I would check is Dashboard -> Options -> General and make sure you have the right URLs in there. I'm leaning towards that since the non-permalinks look like what you're reporting.

    Hope this helps,
    -drmike

  3. winefornewbies
    Member
    Posted 7 years ago #

    Hi drmike --

    Thanks for the reply. Nope, not some automated or recent install (other than I upgraded to 2.1, but the problem pre-existed the upgrade). And yes, it even does it in the Meta sidebar links.

    I tried replacing the Dashboard>Options URLs, but they only managed to break the blog and I had to go in with phpmyadmin to repair the break.

    But, let's try replacing the URLs again and see what happens. As Samuel L. Jackson said in "Jurassic Park," hold onto your butts...

    I'll report in with the results.

  4. winefornewbies
    Member
    Posted 7 years ago #

    As I was afraid, when I changed the WordPress address to sitename.net and hit the Save button, it choked and gave me an internal server error. phpMyAdmin has repaired the self-inflicted injuries. The same thing happens if I change the blog address.

    It *seems* like those two things should be what I need to tweak, but there's something deeper.

    Any suggested next steps?

  5. moshu
    Member
    Posted 7 years ago #

    If it is about the blog linked to your profile - it doesn't display that strange url but it gives an internal error 500 for every link.

    What if you set the permalink options to the default?

  6. vkaryl
    Member
    Posted 7 years ago #

    What's inside the <title></title> tags in the head tagset in the header.php file?

  7. winefornewbies
    Member
    Posted 7 years ago #

    I just used phpMyAdmin to change the "home" option back to the long pair.com address, which should hopefully put things back to "normal". :-)

    Let me try the default permalink idea.

    Thanks for the suggestions!

  8. moshu
    Member
    Posted 7 years ago #

    Actually, BOTH the home and site-url values should be example.com - nothing else!

  9. winefornewbies
    Member
    Posted 7 years ago #

    After getting things back to "normal" so they are working, I tried the default permalink setting.

    Still running into the same issue that brought me here originally. I'm back to square one, but at least links are functional again.

    This is turning into a real mystery. I guess I'm glad it wasn't something simple that I was overlooking.

    Does the internal server error give us any clues?

  10. winefornewbies
    Member
    Posted 7 years ago #

    Holy cow, Moshu, that did it.

    I know what messed me up--the help information on having a different directory made me think I shouldn't touch that second option.

    Thanks everyone for the suggestions and help. I'll gladly mark this thread as resolved!

    Bill W.

Topic Closed

This topic has been closed to new replies.

About this Topic