WordPress.org

Ready to get started?Download WordPress

Forums

Pagination works on Mac, not on Windows (2 posts)

  1. jsoningram
    Member
    Posted 1 year ago #

    Pagination... I'm stuck. I have a template page that is set as my static front page at http://flatiron.morecabbagebeta.com. Pagination works great on the Mac, but not in Windows. What am I doing wrong? Here's the code:

    <div class="text">
    
            <?php if ( function_exists('yoast_breadcrumb') ) {
                yoast_breadcrumb('<p id="breadcrumbs">','</p>');
            } ?>
    
            <h1 class="index_title"><?php the_title(); ?></h1>
    
                        <?php $paged = (get_query_var('page')) ? get_query_var('page') : 1;
                            $args = array(
                                'orderby' => 'date',
                                'order' => 'DESC',
                                'paged' => $paged,
                                'posts_per_page' => 4,
                                'ignore_sticky_posts' => 1
                            );
                            $wp_query = new WP_Query($args);
                        ?>
    
                        <?php if ($wp_query->have_posts()) : ?>
    
                        <div class="navigation"><?php include_once('_/inc/mega_nav.php'); ?></div> <!-- end navigation -->
    
                        <?php while ($wp_query->have_posts()) : $wp_query->the_post(); ?>
    
                            <article <?php post_class(); ?>>
    
                                <?php the_post_thumbnail('index-image'); ?>
    
                                <?php include (TEMPLATEPATH . '/_/inc/meta.php' ); ?>
    
                                <h2 class="blog-entry-title" id="post-<?php the_ID(); ?>"><a href="<?php the_permalink() ?>"><?php the_title(); ?></a></h2>
    
                                <div class="blog-entry-content">
                                    <?php the_excerpt(); ?>
                                </div>
    
                            </article>
    
                        <?php endwhile; ?>
    
                        <?php else : ?>
    
                            <h2>No posts yet</h2>
    
                        <?php endif; ?>
    
                        <?php wp_reset_postdata(); ?>
    
        </div> <!-- end .text -->
  2. jsoningram
    Member
    Posted 1 year ago #

    I fixed this by using the standard loop and not a page template and then setting my front page to static. Still curious as to why this wouldn't work only in Windows.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags