WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Pagination problem (23 posts)

  1. worldblogosphere
    Member
    Posted 3 years ago #

    Hi,

    Well I have worked through so many issues over the past week and a half. I went from having my WordPress MultiSite blogging network on a shared HostGator server to HostGator's VPS server. After they transferred my site NOTHING worked. Pages were loading almost never. My busiest site went from 3000 unique visitors a day to 50 due to never loading pages. They couldn't or wouldn't help me fix whatever the issue was. So, after researching their 45 day refund policy I up and moved everything over to a new Shared Server GoDaddy account. They told me what I had would work on their shared server due to a different setup. I was told to install through their WordPress app because then they could offer me more support for it since it was their install. Well support was helpful throughout my 28 calls in 3 days, but still the site was not setup properly. For some reason the software wasn't working well with the database even after changing everything that should have fixed it.

    That is when I decided to go rogue and do my install since their support wasn't all that good, and with every third person telling me they offer no help for WordPress (their install or mine).

    I went and installed WordPress MU 3.0. My thought process was that my site was originally an MU site, so the structure would be there and then I could upgrade to WP Multisite 3.0.1 . Well, using my own knowledge of working through many problems I got it all set up correctly. Well mostly!

    Today I had an issue with no one being able to comment...after removing the Antispam code from the htaccess file people can comment again.

    It seems the only problem I have left is pagination in many places. Here is an example of what I am talking about.
    http://extraordinaryintelligence.com/index.php?s=news

    Scroll to the bottom and click Next Page. I have a feeling the problem is somewhere in my htaccess file. I am attaching the code from that file below. Also, any time I change permalinks nothing happens to the htaccess file.

    Thanks for any help,
    Gene

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/home/content/b/l/o/blogamerica/html/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) "/home/content/b/l/o/blogamerica/html/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{DOCUMENT_ROOT}/home/content/b/l/o/blogamerica/html/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) "/home/content/b/l/o/blogamerica/html/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html" [L]
    </IfModule>
    
    # END WPSuperCache
    
    RewriteEngine On
    RewriteBase /
    
    #uploaded files
    #RewriteRule ^(.*/)?files/$ index.php [L]
    #RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
    
    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  2. If you're running multisite and you change permalinks, unlike a single install it will not update the htaccess file for you.

    That "no input file specified" error I usually see on Nginx servers. Do you know what kind of OS is on your webserver?

  3. worldblogosphere
    Member
    Posted 3 years ago #

    Hi Andrea,

    Getting this direct from my GD panel...

    OS/Hosting Type: Linux/Shared Hosting

    with PHP 5.X if that matters.

    Main reason I asked about the htaccess file being updated was because I was trying to clean it all out. I had to remove the Antispam code suggested by WordPress (and you I believe) because with it in people couldn't comment about half the time. That was for known members too, not just new people.

    Does the rest of the htaccess file look normal?

    Thanks for the help.

  4. Uh, no. you've got two chunks of wordpress-specific stuff in there AND a whole pile from supercache.

  5. worldblogosphere
    Member
    Posted 3 years ago #

    I have no clue how the two bits of WP code got in there, thought it looked very similar. How do I tell which is correct?

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    That one or this one?

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    As for the Super Cache code, that is the exact code it loaded on its own. Is there not supposed to be that much?

    I can't seem to find the link back to the Antispam code. Is there any reason it would be causing people to not be able to comment on posts? People were getting page not found erros when clicking submit.

  6. The first one is the multisite htaccess code so the blogs will show up.

    the second one is single WP. Get rid of it.

    When enabling the network, it states to *replace* the default htaccess rules, not add.

  7. And it looks like you had an old WPMU .htaccess in there, which SHOULD still work but ... Here's the correct one, full and true, with your SuperCache stuff at the top. FYI, this is for a SUBfolder MultiSite. If you have subdomains, it'll be a little different.

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/home/content/b/l/o/blogamerica/html/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) "/home/content/b/l/o/blogamerica/html/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{DOCUMENT_ROOT}/home/content/b/l/o/blogamerica/html/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) "/home/content/b/l/o/blogamerica/html/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html" [L]
    </IfModule>
    # END WPSuperCache
    
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress
    
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
  8. worldblogosphere
    Member
    Posted 3 years ago #

    Thanks Andrea and ipstenu!

    The bottom single WP one I put in there manually in an attempt to fix it. What was actually in there was missing a couple lines. I didn't realize it was for single version.

    I actually do have a subdomain setup. What is it that needs to be different?

    Thanks again for the help.

  9. Replace

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    With

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress
  10. worldblogosphere
    Member
    Posted 3 years ago #

    Thanks for the quick response ipstenu! All the updated code is in now and seems to be working. Thanks.

    So did anyone have any thoughts on how to fix the pagination problem?

    It seems the only problem I have left is pagination in many places. Here is an example of what I am talking about.
    http://extraordinaryintelligence.com/index.php?s=news

    Scroll to the bottom and click Next Page.

  11. Okay. Turn OFF pretty permalinks for that site.

    It looks like your domain isn't parsing them correctly.

  12. worldblogosphere
    Member
    Posted 3 years ago #

    Thanks again ipstenu.

    I came across a new issue thanks to the spam sign ups I have been getting, but I am putting it in a new post since it is completely unrelated.

  13. Well, turning off Pretty Permalinks isn't a fix :) It's more of debugging. IF your site works with Ugly Permalinks, then you go back to your host and tell them 'Hey, it's not parsing .htaccess correctly!' They can fix that.

  14. worldblogosphere
    Member
    Posted 3 years ago #

    Well GoDaddy ran some tests and they say everything is parsing correctly. They say the issue is with an incomplete header. They have sent me the information to fix it, but I haven't gotten to that point yet.

    Thanks again for all the help.

  15. Yeah, I have gotten similar errors on GoDaddy-based sites before.... they even make the signup page render a 404 in the title bar & still generate the page.

  16. worldblogosphere
    Member
    Posted 3 years ago #

    After further review the info they sent explained how to change the file type. I don't see how that is supposed to help anything. Whatever he checked in his test though changed the error I am getting.

    Now when you go to
    http://extraordinaryintelligence.com/index.php?s=news

    Scroll down and click Next Page you get the following error.

    Fatal error: Call to undefined function get_header() in /home/content/b/l/o/blogamerica/html/page.php on line 1

    The first line of page.php is of course the php code calling the header.

    Any thoughts on what I can do to fix this evolving problem?

  17. What folder, on the server, is WordPress installed in?

  18. worldblogosphere
    Member
    Posted 3 years ago #

    It is in the root directory.

  19. So /home/content/b/l/o/blogamerica/html - correct?

  20. worldblogosphere
    Member
    Posted 3 years ago #

    Yes, correct.

  21. So... why is there a page.php in the root? That isn't a default WP file.

    If it's not there, then look in your theme files and see if it's calling that page somehow.

  22. worldblogosphere
    Member
    Posted 3 years ago #

    I have no idea why there is a page.php file in the root. It is definitely there though.

  23. worldblogosphere
    Member
    Posted 3 years ago #

    Removing it did indeed fix the problem though!

    Thanks for the help again. I really do appreciate the assistance working through all these issues.

Topic Closed

This topic has been closed to new replies.

About this Topic