WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Pagination / Permalinks not working (8 posts)

  1. pplong
    Member
    Posted 3 months ago #

    I can't get pagination to work properly when using 'pretty' permalink settings.

    Let's say I have a gallery that is split over 4 pages.

    Page 1 shows fine. URL is [domain]/[page name]
    Page 2 will work, and will give the URL [domain]/[page name]/nggallery/page/2
    Page 3 will work, but give the URL [domain]/[page name]/nggallery/page/3?q=/[page name]/nggallery
    Page 4 will result in a 404 error, because the URL its creating is [domain]/[page name]/nggallery&q=/[page-name]/page/4.

    It doesn't actually matter what order I try the pages in, the permalinks just seem to get increasingly complicated, until the point where it doesn't work after the third page.

    If I reset my permalink settings back to default, with ugly page names, it works just fine.

    I've researched the problem as far as I can, and initially it seemed that a fix was simply to reset the permalink settings (save to default, and then save back to pretty permalinks) but this hasn't made any difference.

    I've deactivated all other plugins, cleared the cache, and I still get the same problem. I thought initially that the permalink settings in the WordPress SEO plugin might have been conflicting, but the same problem exists when it is deactivated.

    Everything is latest version - WP3.9.1, NextGen 2.0.65, and I'm running on a Linode VPS with nginx.

    You can see an example of the issue at http://client1.themooringsbushey.co.uk/our-twin-club/

    Any help or advice much appreciated

    thanks

    https://wordpress.org/plugins/nextgen-gallery/

  2. tizz
    Member
    Posted 3 months ago #

    @pplong Does the error still occurs if you active one of the WordPress default themes?

  3. pplong
    Member
    Posted 3 months ago #

    Hi tizz,

    Sorry, I should have said - yes it does, I've just swapped it over to twentythirteen now, same problem.

    thanks for your quick reply

  4. photocrati
    Member
    Plugin Author

    Posted 3 months ago #

    @pplong - Have you tried the Reset Option under Gallery > Other Options and then clearing the image cache under Gallery > Other Options > Miscellaneous *after* refreshing the WordPress Permalinks (switch to default then switch back to your preferred structure)?

    - Cais.

  5. pplong
    Member
    Posted 3 months ago #

    Thanks Cais, but no joy I'm afraid - I did the following:

    - Saved the permalinks back to Default, and then re-saved them as /%postname%/
    - Reset the gallery options;
    - Cleared the image cache.

    But I still get exactly the same behaviour (and I'm still using a default theme, twentythirteen, with all plugins deactivated for testing)...

  6. photocrati
    Member
    Plugin Author

    Posted 3 months ago #

    @pplong - I'll admit to nginx not being one of my strong suits, but is it possible there could be a configuration issue at hand on the server?

    I suggest these references for using Nginx with WordPress:
    http://codex.wordpress.org/Nginx
    http://wiki.nginx.org/WordPress

    Otherwise, it may be best to submit a Bug Report (http://www.nextgen-gallery.com/report-bug/ ... please reference this topic) for this issue so we can get one of our developers to look under the page.

    We will likely need log in and FTP credentials for your WordPress installation, please include those with your Bug Report.

    Thanks!

    - Cais.

  7. pplong
    Member
    Posted 3 months ago #

    it's certainly possible it's related to nginx - I've just tested on apache and you don't get the same problem.

    I'll see if I can drill down on a config problem

    thanks for your help
    Paul

  8. photocrati
    Member
    Plugin Author

    Posted 3 months ago #

    @pplong - If you find something we can help with please let us know, feel free to submit it as a Bug Report (http://www.nextgen-gallery.com/report-bug/).

    Thanks!

    - Cais.

Reply

You must log in to post.

About this Plugin

About this Topic