WordPress.org

Ready to get started?Download WordPress

Forums

Pagination not working with archive.php - Looks like a Permalink Issue (3 posts)

  1. babyboy808
    Member
    Posted 5 years ago #

    Hi Guys,

    Here is a site I am developing: http://www.clients.eirestudio.net/bingo/wp/

    The problem I am having is with the archive.php - When I click on page 2/3 etc of the category (http://www.clients.eirestudio.net/bingo/wp/news/page/2/), Wordrpess can't find the correct page.

    I have tried setting permalinks to default (ugly) and it works.
    And if I add the word category it works also> So why is WordPress not understanding it?

    thanks for any help you can give,
    Keith

  2. nicolaaas
    Member
    Posted 4 years ago #

    I have a similar problem.

    With pretty permalinks settings on, I go to the 2010 (yearly) archives I have 10 post per page. I click on older posts, I get .../2010/page/2 again nice with 10 posts. But then I click older post I go to .../2010/page/3 and there I get 404 not found.

    When I switch settings back to default permalinks, it works just fine. Searched for hours, can find it.
    And it's not logic, because the first two pages work.. only on the 3rd page it fails.

    it's not the plugin's, I tried that.

    Any help would be great!

    http://www.thedaywesurrender.com/state/

  3. scotttswan
    Member
    Posted 4 years ago #

    i expect you may have solved your problem by now but this post came up when i searched for the same problem.

    It was because of the number of posts on my site, In my theme the query was set to showposts=6.
    when it got to page 3 there were only 3 posts to show so it was returning a 404 page for some reason.

    removing this and setting the number of posts to display as 6 in the reading settings of my site fixed this problem

Topic Closed

This topic has been closed to new replies.

About this Topic