WordPress.org

Ready to get started?Download WordPress

Forums

Posts for Page
Pagination not working on main page (9 posts)

  1. benclintz
    Member
    Posted 1 year ago #

    I love this plugin. however, am experiencing some problem. num='5' is displaying 5 posts per page which is OK. However when i click on the "older entries" link the content is not changing. But when i use this code in a sub page it is working as intended. Anyone with an idea?

    http://wordpress.org/extend/plugins/posts-for-page/

  2. vic92
    Member
    Posted 1 year ago #

    Hello, I have the same issue. The 'older entries' link on main page keeps on sendind me back on the main page (hovering the link show mysite/page/2 (???).
    Anyone can help ?

  3. Gary Allman
    Member
    Posted 1 year ago #

    Same problem - using a child theme of Twenty-Twelve. I have specified a page to be the home page, and the older entries feature just brings up the same posts. The address (in the address bar) shows page 2 even though the displayed posts haven't changed.

    The only work around I've found is to remove the "num='5'" parameter, which is not ideal.

    I'll keep the non-working version on my blog for a few days so the problem can be observed. example

  4. benclintz
    Member
    Posted 1 year ago #

    I have moved to pods framework. its a little bit complicated but works fine

  5. GezS
    Member
    Posted 1 year ago #

    Same issue here. I've paginated to 10 entries per page, and whilst the 'older entries' link on homepage takes me to /page/2 as a URL, it just displays the same content as the first page.

    I've tried adding in code to the php file as posted elsewhere on here, but it's not working. So yes, a fix of any kind would be lovely.

  6. RLL18
    Member
    Posted 1 year ago #

    I'm looking for this fix too! Has anyone found a solution??

  7. Franky616
    Member
    Posted 1 year ago #

    I think this is my problem 2 because

    localhost/webs/wordpress/page/3
    shows in the link, and breaks the posts for pages when I click the next button,
    but manualy adding "home" in the url - like
    localhost/webs/wordpress/home/page/3

    works...

    Maybe this will help:
    http://wordpress.org/support/topic/getting-it-to-work-on-my-home-page?replies=2#post-4587731

  8. 1info6
    Member
    Posted 9 months ago #

    I have the same problem. I found it by the administration in Settings - Display-Sets the homepage. If this is not Installation menu, plugin works. The solution but I had not yet found.

  9. Mahellr
    Member
    Posted 7 months ago #

    I'm having approximately the same problem, except that the "older posts" link throws up a page with no posts on it instead, while the URL insists that it is in fact "page 2".

    Like Gary above, I've removed the 'num' parameter, but a better solution would be appreciated if available.

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.