WordPress.org

Ready to get started?Download WordPress

Forums

Pagination not working - All posts still showing on home page (3 posts)

  1. nmstetz9
    Member
    Posted 1 year ago #

    Hi!

    So for some reason my pagination is not working. I am using the theme InDaClub.

    I have made my wordpress reading settings so that only 5 posts should show on the homepage.

    When you scroll down though, all of the posts are shown. It shows 5 posts and then says "Page 2" then shows 5 more posts and says "Page 3" and so on and so forth. Here is my website for reference: http://www.campusvinyl.com

    I don't think it has something to do with an infinite scroll because I have a footer but I'm not totally sure.

    Also here is the coding for my navigation.php (I have not changed it at all):

    <?php global $SMTheme; ?>
    <?php if (!$SMTheme->get( 'layout', 'dpagination' )) { ?>
    <div class='pagination'>
    <?php
    global $wp_query;
    $big = 999999999;
    echo paginate_links( array(
    'base' => str_replace( $big, '%#%', get_pagenum_link( $big ) ),
    'format' => '?paged=%#%',
    'current' => max( 1, get_query_var('paged') ),
    'total' => $wp_query->max_num_pages
    ) );
    ?>
    </div>

    <?php } else {
    $currentpage=max( 1, get_query_var('paged') );
    if ($wp_query->max_num_pages > $currentpage) {
    ?>
    <div class='pagination'>
    ' href='<?php echo get_pagenum_link($currentpage+1) ?>'><?php echo $SMTheme->_( 'nextpage' ); ?>
    </div>
    <?php } }?>

    I am also very new at WordPress and have been holding my own until now. If someone could please help me out that would be great! :)

    Let me know if you need any more information. Thank you again!

  2. Furbaby
    Member
    Posted 1 year ago #

    having same problem... then went and looked at THEIR own page SMTHEMES and same problem on many of their demo pages too..... and cannot get them to answer yet ... :( not happy ... will post here if I hear back from them.

  3. Furbaby
    Member
    Posted 1 year ago #

    TRY THIS PLEASE ... it seems to work for me ....now .....

    This is what worked for me SET your DESIRED amount of posts on first page in the SETTINGS ( READING ) ...

    then in the SECTION for LAYOUT >>> TURN OFF "Load Posts Dynamically" I am using Kitchener theme and this worked for me.

    thanks hope it helps.

Topic Closed

This topic has been closed to new replies.

About this Topic