WordPress.org

Ready to get started?Download WordPress

Forums

Pagination Broken (10 posts)

  1. revlimiter
    Member
    Posted 5 years ago #

    Hey everyone,
    I have an issue with my WordPress blog, http://www.kimstewart.ca/blog/
    When you click "← Previous Entries" at the bottom of the page, it goes to a 404 ( http://www.kimstewart.ca/blog/page/2/ )

    It seems to work without the "blog" in the URL ( http://www.kimstewart.ca/page/2/ ) but that is not what I need. I would like to keep my blog differentiated from my website if possible, by keeping it within the /blog directory.

    Thanks!

    EDIT: Also, I should point out that my WordPress permalink settings are set to "Custom Structure - /blog/%postname%/" ... I hope that helps!

  2. scribu
    Member
    Posted 5 years ago #

    You should remove /blog/ from your permalink structure and add it to your Site URL.

    If you're running WP 2.7 you should upgrade to 2.7.1

  3. revlimiter
    Member
    Posted 5 years ago #

    OK, now I have set my Site URL to http://www.kimstewart.ca/blog/ and it seems to have broke something. I can't even log in to change it back. Please help!

  4. revlimiter
    Member
    Posted 5 years ago #

    And yes, already on WP 2.7.1

  5. revlimiter
    Member
    Posted 5 years ago #

    Nevermind, I found a fix to log back in via this page:
    http://codex.wordpress.org/Changing_The_Site_URL

  6. revlimiter
    Member
    Posted 5 years ago #

    However, now when I set my permalink structure to default
    http://www.kimstewart.ca/blog/?p=123

    and Blog Address (URL) to http://www.kimstewart.ca/blog/

    I get the homepage page (Home) on my blog page... if that makes sense. Any ideas?

  7. revlimiter
    Member
    Posted 5 years ago #

    UPDATE: Ok, It appears that http://www.kimstewart.ca/blog/page/2/ now works! (Pagination within the "blog" directory). I have not modified any more settings. However, the main root directory of my blog " http://www.kimstewart.ca/blog/ " is still not showing the correct page, it is instead showing my homepage...

    Any help is greatly appreciated.

  8. scribu
    Member
    Posted 5 years ago #

    Well, if you'we set the Blog URL to http://www.kimstewart.ca/blog/, that's the correct behaviour.

    There are two issues with your initial permalink structure: /blog/%postname%/

    1. The correct page links are at /page/2
    2. The template tag generates /blog/page/2

    I don't know if the bug is at 1. or 2., but there certainly is one.

    You still haven't told me which template tag your theme uses for pagination, so that I can submit a trac ticket.

  9. revlimiter
    Member
    Posted 5 years ago #

    I'm not sure what you mean by "template tag", can you please clarify? :)

    Thanks for all the helpful info!

  10. scribu
    Member
    Posted 5 years ago #

    Nevermind. :)

    You're welcome.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags