WordPress.org

Ready to get started?Download WordPress

Forums

FlexiCache
Pages work in FireFox, not in IE (3 posts)

  1. Canned_Heat
    Member
    Posted 1 year ago #

    Theme: Twenty Eleven
    Blog address:
    http://picturenorthcarolina.com/north_carolina_pictures/

    I have two pages.

    When I click on them in FireFox, they work fine. When clicked on in IE, both pages get errors like this:

    Warning: require_once(index.php) [function.require-once]: failed to open stream: No such file or directory in /home/aaaserv/public_html/picturenorthcarolina/north_carolina_pictures/wp-content/plugins/flexicache/standalone.php on line 25

    Fatal error: require_once() [function.require]: Failed opening required 'index.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/aaaserv/public_html/picturenorthcarolina/north_carolina_pictures/wp-content/plugins/flexicache/standalone.php on line 25

    --------------------------
    I deactivated Flexicache, got the same problem.

    I uninstalled Flexicache, I got internal server error

    I have since re-instlled Flexicache and am getting the error as indicated above.

    http://wordpress.org/extend/plugins/flexicache/

  2. Canned_Heat
    Member
    Posted 1 year ago #

    Simon,

    UPDATE:

    I appreciate your hard work and contributions to the WordPress community.

    That being said, this plugin has been way too problematic for me.

    I wish to remove this plugin from my wordpress install as if it never existed.

    Here's what I have done so far:
    - deactivated it
    - uninstalled it
    - edited flexicache out of the htaccess file (which the uninstall did NOT do)

    What else do I need to do to completely remove flexicache as if it were never installed?

    Thanks for your help.

    - Dan

    P.S. if you have any specific questions about the problems I had that could help you improve the plugin, you have full permission to email me. I will help the best I can.

  3. simon.holliday
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Dan,

    Thanks for your feedback and sorry to hear you've had problems.

    From the information you've provided it looks like PHP's chdir() function is failing in the standalone.php file, and it is trying to include a file in the wrong directory.

    I've never seen this before and I don't know why it should fail, unless $_SERVER['DOCUMENT_ROOT'] is not set or is empty in your web server installation. This would be unusual.

    It would be helpful if you could test this for me - if you are happy to do this, create a temporary file (e.g. "phpinfo.php") somewhere on your site containing the following:

    <?php phpinfo(); ?>

    Please visit this in a browser and look for _SERVER['DOCUMENT_ROOT'] in the "PHP Variables" section. It should show the webroot for your site. Let me know if it exists and is correct. Once you've checked you should delete the phpinfo.php file from your site.

    In order to delete the plugin, just remove the entire "flexicache" directory from inside "wp-content/plugins". The plugin does not write data anywhere outside of this directory and does not make database changes.

    You are correct that deactivating does not remove the .htaccess change, but this is explained very clearly in the plugin's documentation page (viewable from the plugin settings in your WordPress admin panel) as follows:

    Important: If you deactivate FlexiCache, you should remove (or comment out) these lines from your .htaccess file first. If you deactivate FlexiCache on an individual blog in WordPress MU or WordPress 3, you should remove the site's hostname from the HTTP_HOST condition before deactivation."

    Hope that helps a bit. Sorry I can't explain your original error yet!

    Si.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic