WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Pages of website returns a WAMP homepage on my LocalHost? (3 posts)

  1. arthurmani
    Member
    Posted 1 year ago #

    Using WAMPSERVER for windows 7, smartgit and Safe Search Replace I have done the following steps:

    Pulled a wordpress code from a github repository using smartgit
    Downloaded the database from the server's phpmyadmin
    Imported it to my localhost's phpmyadmin using WAMP.
    Replaced the strings from url.com to 127.0.0.1/url

    The home page of the website works on the localhost but when I click on one of the menu links I get the WAMP homepage instead of the actual page.

    On the wordpress dashboard, I have checked and the URL on pages has been changed to 127.0.0.1/url which is a good sign.I have also checked in the database the actual name of the the page and even the 127.0.0.1/id page did showed a WAMP home page.

    I have tried renaming index.php to index.php.old and replacing it with the index.php from the root folder of a fresh download of WordPress but it did not help.

    What have I done wrong and what can I check to solve the issue?

  2. arthurmani
    Member
    Posted 1 year ago #

    I have tried the following in WP-Config to use the localhost URL instead of the one saved to the database but it didn't work:

    define('WP_HOME','http://127.0.0.1/website');
    define('WP_SITEURL','http://127.0.0.1/website');

  3. arthurmani
    Member
    Posted 1 year ago #

    Go to settings/permalinks in the wordpress dashboard and update permalinks by clicking twice on save changes. That's all.

Topic Closed

This topic has been closed to new replies.

About this Topic