WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Pages appear in Pages management but isn't working (6 posts)

  1. setatakahashi
    Member
    Posted 7 years ago #

    Hi, I just finished the install of WordPress 2.2.2 and I have a default Kubrick theme.

    On the right, every wordpress blog has an About page and this page is apearing for me but when I click on this link, Apache says that no page is found (404 error). It was working before. I just installed a new theme Wuhan and used for a few moments. So this problem appeared and I deleted my WP install and I redone it.

    The page is appearing it's URL in Pages Management and it's published (I created another page to see this problem and I apparently just saved so I know the difference).

    How can I troubleshoot the problem? What are the steps to determine what the problem is?

    My blog is at setaoffice (dot) com

    Any help is appreciated. Thanks
    Emerson

  2. Chris_K
    Member
    Posted 7 years ago #

    Is there actually an "About" page?
    At first blush, it looks like your Permalinks aren't working.

    If you visit Options -> Permalinks and set them to Default, do links start to work? If so, check the Permalinks page for more info and troubleshooting tips.

  3. setatakahashi
    Member
    Posted 7 years ago #

    There was a previous .htaccess file. I recreated one with touch .htaccess and let WordPress build one.

    But even so, the Permalinks are not working.

    I checked the httpd.conf and my server is loading the module
    setaoffice# grep mod_rewrite httpd.conf
    LoadModule rewrite_module modules/mod_rewrite.so

    What else can I check?

  4. setatakahashi
    Member
    Posted 7 years ago #

    Yes, if I turn off the Permalink options, all links work perfectly.

  5. Chris_K
    Member
    Posted 7 years ago #

    Next would be see if AllowOverrides is properly set in the apache.conf (or whatever alternatives to that exist).

  6. setatakahashi
    Member
    Posted 7 years ago #

    Thanks HandySolo.

    Problem solved.

    AllowOverrides was set to none so, Apache wasn't reading my Rewrite rules.

    I'm still deciding if I where I will keep the rules.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags