WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] pages and post not showing after hosting transfer (14 posts)

  1. ekothari
    Member
    Posted 2 years ago #

    Hi
    I recently transferred my hosting services to yahoo, transferred my website and database.
    But after transfer, none of my links are working on my website. Only the home page is showing. I have checked my wordpress, and all my pages and posts are intact there.

    My website is - http://onergy.in.

    My hosting company says that the content is available on my database, but wordpress is not fetching it, and so they cant help.

    Please help.

    Regards

    Ekta

  2. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Try deactivating your plugins and reverting to the default theme and see if there is any change.

  3. ekothari
    Member
    Posted 2 years ago #

    Nope, still the same:-(

  4. ekothari
    Member
    Posted 2 years ago #

    Do you think I might have missed some files while transferring?

  5. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Do you think I might have missed some files while transferring?

    Quite possible, but WordPress files.

    As I suggested, did you deactivate all the plugins and switched to the theme Twenty Eleven so that you can know if the problem is caused by the theme? Are you using a child theme of suffusion or a child theme?

  6. ekothari
    Member
    Posted 2 years ago #

    I deactivated all plugins, and switched to the default theme. There, even the different pages are not showing up. I think they are showing in suffusion, as its marked as show in suffusion setting.

    - What files should I try reinstalling?

    - Could it be a problem with the chmod? currently its set at 775

    my database has all permissions.

    Its my company website, and its supercritical that I resolve the problem asap.

    Please help!

    Regards

    Ekta

  7. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    You are still on suffusion theme.
    Try this:
    1. Deactivate all plugins
    2. Switch to Twenty eleven theme to rule out the problem is not caused by your theme which seems to be extensively edited (you should not edit the original theme, but create a child theme).
    3. If the problem still persists, activate and deactivate plugins one by one to find if any of the plugins are causing the problem.
    4. After all the steps above, try resetting your permalinks to other than the setting used by you and see the results. You can revert to the current settings afterwards.
    5. You are using an old version of WordPress. Your plugins and themes can be of latest version and create conflicts with the old WP version, especially the suffusion theme is always updated to the latest version by its author. So, update WP to the latest version.
    6. All good servers set their settings to the latest WP versions. So, the server settings can also create conflicts.
    7. The main problem I found was that all links are showing 404 error. That means, there can be changes in URLs while you transferred the hosting.

    If you can do these, I will take a look and tell you what you need to do next.

  8. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Are you using the Basic hosting plan of Yahoo or an advanced plan? What I find is that if you are using the Basic Yahoo hosting, it does not support the minimum requirements of WordPress hosting. Check it for yourself at their site.

  9. ekothari
    Member
    Posted 2 years ago #

    Hey Krishna, thanks for your help.
    I have done all of the above, and checked with Yahoo regarding my plan. They said its not the basic plan, and supports wordpress.
    Please have a look at http://onergy.in and guide. The problem still persists.
    Thanks,
    Ekta

  10. ekothari
    Member
    Posted 2 years ago #

    Its working!!!!!!
    Yeeeeeeeeee!!!!!
    Thanks so much krishna for your prompt help! Really appreciate it!

  11. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Great! I appreciate your efforts.

    Where did you find the problem?

  12. ekothari
    Member
    Posted 2 years ago #

    No idea - I had tried all of this before, the exception being - I used default theme and default permalink option this time!

  13. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Well, that's it. Anyway I appreciate it. Congrats!

  14. germars
    Member
    Posted 1 year ago #

    I was having the same problem and the default permalink helped me too! I think it is something to do with the database address, but this works in the short term for me! Thank you ekothari for posting what fixed it!

Topic Closed

This topic has been closed to new replies.

About this Topic