WordPress.org

Ready to get started?Download WordPress

Forums

Pages along top, not sidebar (24 posts)

  1. tarapig
    Member
    Posted 1 year ago #

    Hi,

    I have recently switched to the Oxygen theme and I'm trying to move my pages (About, etc) to the top of my site, under the header. They are currently inside the Pages widget, in my secondary sidebar. When I move the widget to the "header sidebar", it only displays the link to the About page. It's as though the rest don't fit across the top.

    Can anyone help?

    Thanks,

    Tara
    http://www.sweatlikeapig.com

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

  3. tarapig
    Member
    Posted 1 year ago #

    I didn't think it had anything to do with the theme itself though - surely it would be similar for most themes?

  4. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    No - it varies from theme to theme.

  5. heidhorch
    Member
    Posted 1 year ago #

    tarapig, I am using the Oxygen theme also, just now building my site. I'm having the same problem you mention above, and when I visited your site (it looks great), I see that your top menu bar is in place. How did you fix the issue?
    Thanks.
    PS the link above from esmi is only good if you are a paying member.

  6. tarapig
    Member
    Posted 1 year ago #

    Sure. For a great theme, they certainly don't make it easy, I have to say!

    Go to Appearance>Menus. The primary menu is the one that runs across the top. Scroll down and select the pages/categories you would like to feature in that menu, and then it does all the hard work for you! As you can see, I also added a side menu and a bottom menu.

  7. heidhorch
    Member
    Posted 1 year ago #

    Thank you!
    Yeah, I don't know why they make it so hard to figure out (for newbies, that is).
    Now I just have to figure out the slider widget... :)

    Thanks for your help!

  8. tarapig
    Member
    Posted 1 year ago #

    You will probably need help with that too! I think it's a joke because they make you pay to be a member to find out how to do basic things with the theme. They have a documentation section in the website, which tells you how to add the slider. I spent days trying to figure it out on my own, so I wish someone had helped me! Here is how to do it:

    Usage
    The following steps will teach you how to achieve the structure of the Oxygen demo site. You will also learn the specifics of the theme, which aren’t really that much – it’s made to be as intuitive as possible.
    Login to your WordPress admin panel and navigate to “Pages -> Add New”. Fill in a page title – ‘Home’ for example (doesn’t really matter) and then click the “Template” dropdown list. Select “Front Page” and then click the “Publish” button.
    Go to “Settings -> Reading” and set the front page to display a static page – from the “Front Page” dropdown list select the title of the page we created in the previous step. In my case that was ‘Home’.
    Start adding posts to your site from “Posts -> Add New”. Write title, text, images, video, etc. Choose category(-ies) and tags for the post. Then look at the bottom right panel and set a “Featured Image”. After all is done, there is just one final step – specific for this theme…
    Just under the “Featured Image” box, there is another one – titled ”Location”. If it’s not there, then you need to enable it by clicking the “Screen Options” button (upper right corner) and checking “Location” – then it would appear. This is where you choose where the post should be displayed on the home page.

    Select “Featured” if you want the post to be displayed in the featured content area – as a slide. The next three posts with the wide thumbnails are the “Primary” area. And the remaining 12 posts – presented by their title and metadata only, form the “Secondary” area. So make your choice by clicking one of the radio button and then “Publish” the post. Note: You can remove a post from the home page later – by editing the post and selecting the last option “Do not display”. It will remove the post from the home page (but only from the home page!).

  9. heidhorch
    Member
    Posted 1 year ago #

    Tarapig, let me ask you a question.
    When you look in the mirror, is there a soft golden glow emanating from your head?
    Because you are a GODDESS!!

    You rock.

    Thank you I will post a link when I finally get it up & running - I have to do some extra tweaking because I'm importing from blogger. Plus I have to work today :(

    Thank you, thank you, may you have good karma for a month.

    (Oxygen Theme slider fix.)

  10. tarapig
    Member
    Posted 1 year ago #

    Haha thank you :) I hope it helps! I just know how painful it was when I was trying to do it, so hopefully some other people can find this thread too. I'd love to see the finished product!

  11. marina123
    Member
    Posted 1 year ago #

    Tarapig, I can't fix my slider, waaaah.
    I think because I cant find title 'Location' even if i search in the screen options button.
    Can you help me.

    Thnx

  12. cadcardoso
    Member
    Posted 1 year ago #

    TARAPIG: Thanks for your help but I can't find "and then click the “Template” dropdown list. Select “Front Page” and then click the “Publish” button." _ I follow your steps.. can you help me?

  13. cadcardoso
    Member
    Posted 1 year ago #

    TARAPIG: I also can't find "Just under the “Featured Image” box, there is another one – titled ”Location”. If it’s not there, then you need to enable it by clicking the “Screen Options” button (upper right corner) and checking “Location” – then it would appear. This is where you choose where the post should be displayed on the home page.".. sorry ;P but i'm freaking.. i realy nead to put my blog working.. tanks for your time

  14. saraGI
    Member
    Posted 1 year ago #

    Hi, Sorry to barge into a resolved conversation, but i have another kind of problem, not related to the slider but to the widgets. I saw Tarapig's website and i see that your widgets are in place. My problem is when I try to insert the widgets in the areas, after I save and close, then i leave the page and they are not in the site or in the widget areas anymore. Did you guys have that issue? Thanks a lot!

  15. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    @saraGI: It is impolite and contrary to forum policy to interrupt another poster's ongoing thread with a question of your own. Please post your own topic.

  16. tarapig
    Member
    Posted 1 year ago #

    Sorry, I'm by no means an expert - the instructions above just worked for me. I would suggest joining the devpress forum if you still haven't figured it out. It only costs $5 for one year's access, and they are very good at answering questions quickly.

  17. saraGI
    Member
    Posted 1 year ago #

    Thanks for the answer. I was by no means trying to be impolite. I was just wondering if you had an issue in introducing the widgets or not. I'll try my own topic.

  18. cadcardoso
    Member
    Posted 1 year ago #

    TARAPIG: tanks anyway, i haven't solved my problem because i couldn't find the “Front Page” and the "Location" that you refer .. maybe I will join the devpress

  19. cadcardoso
    Member
    Posted 1 year ago #

    TARAPIG: tanks anyway, i haven't solved my problem because i couldn't find the “Front Page” and the "Location" that you refer .. maybe I will join the devpress

  20. WeeMadAggie
    Member
    Posted 1 year ago #

    I am now stuck on this bit:

    "Just under the “Featured Image” box, there is another one – titled ”Location”. If it’s not there, then you need to enable it by clicking the “Screen Options” button (upper right corner) and checking “Location” – then it would appear. This is where you choose where the post should be displayed on the home page."

    I do not have a "Location" box and I do not have the option to switch it on in the Screen options.

    Is there some magic trick to enabling this other than the Screen Options?

  21. heidhorch
    Member
    Posted 1 year ago #

    Tarapig: It's up & running: http://westceltgypsy.com
    Thanks for all the help!

  22. tarapig
    Member
    Posted 1 year ago #

    It looks awesome! Love your post on 50 Shades - totally agree :)

    You just reminded me that I need to set up Link Within....I can't do it from a Mac (I don't think, anyway) so I will have to do it at work.

  23. ahmadirfan
    Member
    Posted 1 year ago #

    it's working on my site....
    thanks tarapig

  24. lagerstedt
    Member
    Posted 1 year ago #

    As WeeMadAggie I also do not have "Location" box and I do not have the option to switch it on in the Screen options.

    What to do then?

    Please help!

Topic Closed

This topic has been closed to new replies.

About this Topic