WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] page_enhanced sending no-cache max-age:0 headers (3 posts)

  1. adnanoner
    Member
    Posted 7 months ago #

    Hi there,

    I'm using nginx, and browser caching for my disk enhanced page cache. I've selected Set cache control header for the browser caching, and when I look at my headers i see: Cache-Control:max-age=0, no-cache.

    In my nginx.conf file there is

    # BEGIN W3TC Page Cache cache
    location ~ /wp-content/cache/page_enhanced.*html$ {
        expires modified 3600s;
        add_header Vary "Accept-Encoding, Cookie";
        add_header Pragma "public";
        add_header Cache-Control "max-age=3600, public";
    }
    location ~ /wp-content/cache/page_enhanced.*gzip$ {
        gzip off;
        types {}
        default_type text/html;
        expires modified 3600s;
        add_header Vary "Accept-Encoding, Cookie";
        add_header Pragma "public";
        add_header Cache-Control "max-age=3600, public";
        add_header Content-Encoding gzip;
    }
    # END W3TC Page Cache cache

    Which should be ok. Am I missing something?

    Thanks!

    http://wordpress.org/plugins/w3-total-cache/

  2. adnanoner
    Member
    Posted 7 months ago #

    Btw, I am using ngx_pagespeed could be that the combination is causing this?

  3. adnanoner
    Member
    Posted 7 months ago #

    Ok I figured out that ngx pagespeed module adds it. Problem kind of solved, just wondering why it is not caching and setting the date to 1970.

Reply

You must log in to post.

About this Plugin

About this Topic