WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Page width too narrow and wrapped menus (7 posts)

  1. pwforaker
    Member
    Posted 2 years ago #

    I'm fairly new at WP. I've installed a 2011 child theme at http://www.metacultura.org. I want the page to display at 1000px wide (like my other site at http://www.aguilateam.com/), but it comes up at 690 px, and the menu is wrapping to multiple lines. (Is this two problems, or one?)

    The header image is exactly 1000x288. I've made only minor changes in the style.css file. I have installed no widgets, and the following plugins are active: Form Manager, Members Only, and Simple Login Log. The page default is set to one-column, no sidebars. All the pages are using the Showcase Template. I've turned off the custom menu. No help.

    I have another site at http://www.integralview.org that is also using the 2011 theme and it, too, displays at 690px.

    Where do I look to get the Metacultura site to format at 1000px, and stop the menu items from wrapping?

  2. TheFreeWorld
    Member
    Posted 2 years ago #

    In The Style.CSS file of your theme you should be able to change the Width.

  3. pwforaker
    Member
    Posted 2 years ago #

    Thanks, I tried that. Putting body{width="1000px";} into the style.css does not affect the width of the page. Nor does it touch the menu-wrapping issue.

  4. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    your 'metacultura' link askes for login :-(

    here is the limiting style:

    /* One column */
    .one-column #page {
    	max-width: 690px;
    }

    with the menu, it might be this style:

    #branding .only-search + #access div {
    	padding-right: 205px;
    }

    if you want further help, make your site freely accessible.

  5. pwforaker
    Member
    Posted 2 years ago #

    Thank you, alchymyth. I forgot about the members-only setting. Sorry about that. It's now open to visitors.

    I added the one-column and branding elements to my custom style sheet, saved the changes, reloaded the front page. No change. Still 690 wide and wrapped menus.

  6. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    there is some invalid code in the css section of style.css of the child theme;

    should be:

    body{
       width:1000px;
    }
    
    p{
       text-align: justify;
    }
    
    #site-title a {
        color: #009900;
    }
    
    .recent-posts {
    display:none;
    } 
    
    #branding #searchform {
    display:none;
    }
    
    .entry-content table,
    .comment-content table {
    	border-bottom: 0px none #ddd;
    	margin: 0 0 1.625em 0;
    }
    
    /* One column */
    .one-column #page {
            max-width: 1000px;
    }
    
    #branding .only-search + #access div {
            padding-right: 20px;
    }

    http://www.w3schools.com/css/

  7. pwforaker
    Member
    Posted 2 years ago #

    Great. Thank you very much. That did the trick. Obviously, not all : are =. :)

Topic Closed

This topic has been closed to new replies.

About this Topic