WordPress.org

Ready to get started?Download WordPress

Forums

Page Title vs. Blog Title (6 posts)

  1. misty9
    Member
    Posted 6 years ago #

    I've noticed that my Blog Title is in every single page of my blog, when viewing the Page Source in the browsers.

    How can I change it so that the actual Page Title is between the Title tags instead of the Blog Title?

    Thanks.

  2. Len
    Member
    Posted 6 years ago #

    It's probably a good idea to leave the blog title in there. Look in header.php (toward the top of the document) for <title> blah blah blah </title> and replace with this,

    <title><?php bloginfo('name'); ?><?php wp_title('-'); ?></title>

    This will output the blog title on the home page. On single post pages it will output > BlogTitle-PostTitle

    On category pages it will output > BlogTitle-Category

    and so forth.

  3. misty9
    Member
    Posted 6 years ago #

    Thanks Len!

    I've edited the Webblog Title field in General Options of WP after posting this question. The following default code in Header.php seems to handle Blog Title and Page Title accordingly:

    <title><?php bloginfo('name'); ?> <?php if ( is_single('1') ) { ?> » Blog Archive <?php } ?> <?php wp_title(); ?></title>

    The output format of a Page Title in the View Source looks like this:

    <Title>Webblog Title "&raquo"; Page Title</title>

    How can I replace "&raquo" with a colon so that it would look like this?
    <Title>Webblog Title: Page Title</title>

    Thanks.

  4. moshu
    Member
    Posted 6 years ago #

    The raquo comes from the core WP files... which means you need to edit those + do it again every time you upgrade.
    Maybe a better solution is to use a plugin, like
    http://wordpress.org/extend/plugins/seo-title-tag/
    or something similar

  5. misty9
    Member
    Posted 6 years ago #

    Thanks much, Moshu. I've installed the SEO Title Tag plugin, which is a great plugin. It also has "&raquo" between the <title> tags.

    It seems that "&raquo" is how it appears between the <title> tags when viewing source. But It shows the arrow sign » if post it here:

    <Title>Webblog Title » Page Title</title>

  6. moshu
    Member
    Posted 6 years ago #

    If you have it installed... just go back and read again and again the settings options (regarding raquo, if you don't want to use it)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.