WordPress.org

Ready to get started?Download WordPress

Forums

Page Templates in WordPress 2.5?! (57 posts)

  1. mrleesimpson
    Member
    Posted 6 years ago #

    Hello.

    I've just installed WordPress 2.5 as part of a client development. Everything is going find except I can't find where to select 'Page Templates'?!

    Looking at other posts I know is suppose to appear between Page Parent and Page Order at the bottom of the Page editing page, but it just ain't there?

    I've created the page and inserted the necessary Tags...

    <?php
    /*
    Template Name: Clients
    */
    ?>

    But still no joy.

    Anyone got any ideas?

  2. mrleesimpson
    Member
    Posted 6 years ago #

    Can't anyone shed any light on this?!

    I really need a fix for this ASAP.

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Are you sure you're writing a Page and not a Post?

    Also, check that you have the page template in your theme directory and that it is accessible (644 permissions). WordPress will not show the page template box if it cannot find any page templates in the theme.

  4. mrleesimpson
    Member
    Posted 6 years ago #

    Otto. Cheers for getting back to me.

    I'm deffinitly writting a Page and not a Post and I've tried all permissions to get it to work but still nothing.

    I've been working with WordPress for as long as I can remember and only yesterday I did this exact same thing in 2.3.3. Today in 2.5....nothing.

    I've found a few more posts with this problem including this one http://wordpress.org/support/topic/161730?replies=2, but no solutions.

  5. mrleesimpson
    Member
    Posted 6 years ago #

    Well I've just re-installed 2.3.3 and now the problem is solved and the Page Templates are working fine!

    Something to look at guys!

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Well, I just decided to try it myself, since I don't have any templates. I created this one:

    <?php
    /*
    Template Name: Test
    */
    ?>

    Uploaded it to my theme. Voila, it works fine, the template box appears and shows "Default Template" and "Test".

    Don't know what to tell you, but this is not a 2.5 problem.

  7. mrleesimpson
    Member
    Posted 6 years ago #

    Well since I did this I've spoken to 3 other people who are long time WordPress users and they have had the exact same problem with 2.5 (and as it happens all went back to 2.3)....

  8. krille83
    Member
    Posted 6 years ago #

    Same problem for me, long time WP user. Templates works fine in 2.3, but not in 2.5. Checked permissions and so on, nothing...

  9. bugajski1
    Member
    Posted 6 years ago #

    same here this is so crazy how huge this is they just overlooked this very basic thing????? help!! rest i like so far MUCH cleaner but dang no page templates!?

  10. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Well, okay, I don't know what to tell you guys.

    Here's what I see:
    http://img187.imageshack.us/img187/5516/templateuc3.png

    All I did was to create a test.php file in my theme folder with the content I gave earlier. That's it. It worked instantly.

    I looked through the code, and the only limitations I see are that the filename must end with ".php" and it must be readable and it must have that "Template Name:" code in it.

    That's really all I can tell you, it simply works. That functionality has not changed in any major way since 2.3.3. There's nothing functionally different there.

  11. bugajski1
    Member
    Posted 6 years ago #

    ok i'm seeing the template box now ..have no idea how i fixed it but here's what i did

    ..i created a new page with 2.5 installed ..i copied my template directory uploaded the copy ..... then i deleted a category ...

    more stuff seemed to appear on the right column after switching to the copy of my template

    after i deleted a category i went back to the page ...and there it is the template drop down list thank thee lord!

  12. mrleesimpson
    Member
    Posted 6 years ago #

    I tried this ^^ and still nothing.

  13. kobak
    Member
    Posted 6 years ago #

    Same for me. No page templates. Don't understand...

  14. webwisedesign
    Member
    Posted 6 years ago #

    Otto, I too am not having any luck at this. Could you tell me what the exact procedure you used was? I opened my page.php file in my theme (assume you can use the index.php file as well), placed the specified code (see below) at the top of the page, renamed the page test.php and uploaded it into the root of my theme directory (wp-content/themes/ww2col/), made sure the test.php file was CHMOD 644.

    Code used:

    <?php
    /*
    Template Name: test
    */
    ?>

    I then went back into my admin area, went to create a new page, Nothing.
    Went to edit an existing page, Nothing. The admin area still gives me no templates.

    http://www.steffels.com/wp-admin-no-template.png

    I assume I am overlooking something obvious, but have no idea what it is. This is VERY frustrating to those of us who are not able to make this work.

  15. studio-racket
    Member
    Posted 6 years ago #

    I am having the same problem... I am done this a squillion times in 2.3... doing nothing differently... other than getting a shock, drinking too much coffee and swearing at inanimate objects.

    The shiny drop down box is simply not there.

  16. studio-racket
    Member
    Posted 6 years ago #

    Just checked a different install of 2.5 I have running for a different project - and the afore mentioned shiny drop down box appears fine... the version which works fine was the sneak peek before the official release... did anything change between versions?

  17. webwisedesign
    Member
    Posted 6 years ago #

    OK, so I have ruled out caching issues in FireFox and IE by going on different computers, even non-networked computers and I still get the same thing. I am only running one version as I have not upgraded yet on other installations.

    Is this a plugin or settings issue?

    I have Akismet, Search Everything, and wpSEO as plugins on my installation. Disabling these plugins has no affect.

    This leads me to believe this is a setting issue or something drasticly wrong with an upgrade.

    Does this happen on New installs or just upgrades?

  18. Monika
    Member
    Posted 6 years ago #

    silly

    but: use default theme -- surf a while with default theme,
    after this change to your preferred theme

    maybe WP *insideCache* can't remember ...

    WP 2.3.3 any developer Version of WP 2.5 and I have the dropdown for individual page templates

    regards

  19. kingofmycastle
    Member
    Posted 6 years ago #

    Just to add to this, my Page Template box comes and goes as it pleases. I made two template and was able to change between them all yesterday. Then today they disappeared. Five minutes ago they came back again!

    I'm using WP 2.5, Firefox and my install is on my PC/localhost.

  20. webwisedesign
    Member
    Posted 6 years ago #

    Monika, did you change anything? Any settings or did you upload another file of some sort? Sounds too much like voodoo. Tried it and no luck. Added another user and the "Page Author" shows up.

    I am now thinking of restoring my previous version of WP.

  21. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    webwisedesign: I did literally nothing more than what you're saying. Make a php file, stuck that header into it, uploaded to my theme directory and that was it. I did nothing else of any kind.

    Try switching to the default theme and back. I dunno. What you and others are telling me doesn't make any sense. I believe you, but I don't see how it's possible. The code works very simply, there's really no room I can find for it to not work.

    Possibility: Maybe you did not upload all the wp-admin and wp-includes files? Did you overwrite? Perhaps you have some old 2.3 files lying around somewhere that are interfering? I can't think of *any* reason that a normal 2.5 installation would do this, but if you have some kind of weird hybrid, then anything is possible, I guess.

  22. webwisedesign
    Member
    Posted 6 years ago #

    Yes Otto, I thought of that too, but it appears (after checking my 2.3.3 backup and the live 2.5) that the only things that were unchanged are my htaccess file, wp-config file, and the plugins Search Everything and wpSEO. The Akismet plugin was updated after the update to 2.5. I did try disabling all the plugins, but still no luck. I don't consider myself a Newby at WP (having developed my own themes and have used WP as a CMS) but I now feel like one. I am using this install as a CMS and therefor the page template issue is very important. This upgrade is my test and I am not comfortable yet with upgrading the rest of our sites and blogs. Sorry, I am probably venting as I too can see no reason for this.

  23. Monika
    Member
    Posted 6 years ago #

    my switch-example is no *vodoo* /laughing,

    but it is a simple method to clear browsercache because sometimes browsercache is harder to clear than to code a bugfree WP ;)

    ;)

  24. Eric Amundson
    Volunteer Moderator
    Posted 6 years ago #

    I noticed the same issue and like Monika had a similar fix. Not sure it always works yet, but here's what I did:

    After upgrading a site from 2.3.3, it was using the same theme I'd used in the past. When I tried to write a page based on a template, I didn't see the dropdown.

    So, I jumped over to Design and selected my desired theme again.

    Then, switching back to the page I was writing, the Page Templates dropdown appears where it should be.

    Hope this helps.

  25. KK3
    Member
    Posted 6 years ago #

    I had the same problem (which is how i found this post). No matter how many times I refreshed and checked my code I couldn't find a solution. But then I changed my template to Default template and then back to my custom template, went to Manage -> Pages, chose my page, and the page template box now displays.

  26. Kathi
    Member
    Posted 6 years ago #

    I don't know if this helps. A bit redundant, but I could not get the Page Template dropdown box either. I tried REFRESH but it did not help me.

    But what appears to have worked is when I cleared all PRIVATE DATE informaton in firefox (Tools/Clear Private Data/Browsing History, Saved Form Search History, Cache and AUTHENTICATED Sessions) BEFORE clicking on REFRESH on the WordPress/Write/Page

    This is probably obvious to all of you - but be sure the template name in your code matches the name of the new php file. This had happened to me "way back", I had used - in the template name, but named the file with an underscore _(a note in case a newy like me visits this blog!)

    Open: page.php
    Rename file for example: photography.php
    Insert code at the top

    <?php
    /*
    Template Name: photography
    */
    ?>

    Fortunately, I'm one of the blessed right now who can see the dropdown box!

    Kathi

  27. kobak
    Member
    Posted 6 years ago #

    switch to default theme and then back to my theme helped.

  28. karmadude
    Member
    Posted 6 years ago #

    switching to default theme and back worked for me as well.

  29. webwisedesign
    Member
    Posted 6 years ago #

    Sorry Ladies and Gentlemen, I am heading back to 2.3.3. If this were a caching issue it would have been resolved last week as I have tried this on several computers including one not on our network (not even through the same ISP) and have repeatedly emptied the cache from IE and FF in an attempt to get this to work. Tried every option of themes (Switching from default to any of our three standard and tested themes too many times to count), then went back to 2.3.3 (where templates worked) and reinstalled 2.5 - all to no avail. I may try again when 2.5.1 comes out. :(

    Thanks to all but this issue has not, as of yet, been resolved.

  30. lipsk
    Member
    Posted 6 years ago #

    I tried switching to default and back and it worked for me.

    Maybe it's not a caching issue but an internal field that WP sets when switching themes... something like that...

Topic Closed

This topic has been closed to new replies.

About this Topic