WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Page template problem (8 posts)

  1. albinjoseph
    Member
    Posted 3 years ago #

    Hi,

    My wordpress is not using the page template for the pages, and it is just displaying the index page whenever I try to access any page. To troubleshoot the issue, I tried to use a custom template also for one of the page(My url was http://localhost/wordpress/contact and the custom template I have added was page-contact.php). However even this was not working. The theme I am using is twenty eleven.

    thank you for the help.

    thanks
    -Albin

  2. albinjoseph
    Member
    Posted 3 years ago #

    The problem exist for any theme I am using.

  3. albinjoseph
    Member
    Posted 3 years ago #

    The only plugin I am using is the Custom Post type UI. If I deactivate the plugin everything is working fine.

  4. spstieng
    Member
    Posted 3 years ago #

    Have you tried updating your permalink structure?

  5. albinjoseph
    Member
    Posted 3 years ago #

    Yes I did update my permalink structure and it did not work.

    Now I use a different plugin for creating the custom post type and everything is working fine :-).

    This looks like a bug to me in Custom Post type UI plugin. The steps to replicate the issue. Install a fresh copy of wordpress 3.2.1 and install the plugin. Create a custom post type and add taxonomy to it. Now go to permalink to refresh the rules. Create a new page and try to access it. Instead of the page, the index page will be shown.

    Thank you for the help.

  6. noelhefele
    Member
    Posted 2 years ago #

    Same issue here I think. It's a bit maddening! Custom post type works, but other pages show index page.

  7. albinjoseph
    Member
    Posted 2 years ago #

    I got the problem finally. Its not a bug in the plugin. One of my taxonomy had a wordpress reserved word as the name and it created the issue.

  8. noelhefele
    Member
    Posted 2 years ago #

    It isn't a bug for the plugin - for me I got it to work with the permalinks.

    I had to add a real word to the permalinks --- i.e. (artworks/%year%/%monthnum%/%gallery%)

    I then used the Custom Post Type UI (enhanced) plugin, which has a rewrite front option.

    Seemed to have solved the issue.

    Making sure to not overlap custom names also seems very important...

Topic Closed

This topic has been closed to new replies.

About this Topic