WordPress.org

Ready to get started?Download WordPress

Forums

Page Template Changes Not Showing (4 posts)

  1. OliverWKim
    Member
    Posted 1 year ago #

    I'm dealing with a weird and very annoying bug where changes to a page template file ("contact.php") are not being registered at all by WordPress.

    I've made sure that the template has been correctly selected by the pages that are supposed to use it. The pages also clearly use the layout specified by the template, but they don't register any changes, even when I add huge globs of texts in the middle. Nothing shows up. This problem applies to every new page I create, as well as old pages I modify.

    I don't have any caching plugins installed, so I am at a loss as to why this is the case. Changes to other parts of the website (for example, header.php) show up just fine. Switching to another theme then switching back doesn't help either. This is immensely frustrating, and I'd be grateful for any help.

  2. ssteiner
    Member
    Posted 1 year ago #

    I am having a similar issue but with WordPress ignoring the template I set and reverting to the default template on my home page.

    Since the content item is blank (all output is supposed to be handled by the template), I can't figure out why it's using the original page.php or where it's getting the content.

    It keeps displaying the old content and, like you, I have no caching plugins enabled at all.

    So my issue seems to be that the old version of the page is cached somewhere and I can't make it stop.

    S

  3. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @ssteiner - per the forum guidelines, please start your own thread.

    @OliverWKim - what theme are you using? A link to your site might be helpful as well.

  4. ssteiner
    Member
    Posted 1 year ago #

    I didn't start a new thread, because I believe this could be a related issue.

    Template changes not being reflected in front end, and an old version of my content were both solved in my case by completely nuking the supposedly inactive w3-total cache. I had activated it at one time, and deactivating it did not actually disable it completely.

    S

Topic Closed

This topic has been closed to new replies.

About this Topic