WordPress.org

Ready to get started?Download WordPress

Forums

Page Template Being Ignored, Showing Media Attachment Instead? (3 posts)

  1. brycebertola
    Member
    Posted 3 years ago #

    Hello all, so I am working on a website and I am running into an extremely puzzling issue.

    The site: http://garterglitz.com - It is a site for a friend who makes custom, handmade bridal garters.

    The issue: I have created a custom page template for each of the garter pages. Each page should show a picture, the description, an add to cart section, and a general information area with sizing details.

    Each of them has been created as a page, with the custom page template "Garter Page" - an example at http://www.garterglitz.com/our-products/anny-2/

    The problem is that a few of these pages are being mysteriously replaced with a different theme, resembling an attachment post. an example is here http://www.garterglitz.com/our-products/babe/

    Now my question is this, I have checked the page template a hundred times, that's correct, I've checked the slug a hundred times, that is also correct. I am befuddled as to why the page would load an ENTIRELY different template than what it is instructed.

    Please help.

  2. vtxyzzy
    Member
    Posted 3 years ago #

    I don't know if it is the same or not, but I had a very similar issue where a page did not load the template I thought it should.

    I was trying out a new version of the template and had renamed the old one by adding -hold to the name - but I forgot to change the Template Name line in the code. For some unknown reason, the -hold version would get loaded part of the time.

  3. brycebertola
    Member
    Posted 3 years ago #

    Unfortunately that isn't it. I was planning on doing an update for 3.0 soon, perhaps this is a sign to just start it up now.

Topic Closed

This topic has been closed to new replies.

About this Topic