WordPress.org

Ready to get started?Download WordPress

Forums

Page Tabs don't show URL (25 posts)

  1. rrglare
    Member
    Posted 1 year ago #

    Page tabs in browser show up as "type here anything you want" when accessed normally through several browsers. When accessed from the dashboard they do show up correctly with the site URL. (Using 2010 theme.)

    I've thoroughly reviewed all design options and done many info searches to no avail. Visitors cannot share accurate links to my site because the url is not there, and if they copy and paste the site url they can only get the static home page with "type here anything you want"

    Thank you very much

  2. David Choi
    Member
    Posted 1 year ago #

    Sorry, can't really understand the problem. Can you provide your site's URL?

  3. rrglare
    Member
    Posted 1 year ago #

  4. rrglare
    Member
    Posted 1 year ago #

    You will note that the tab at the very top of the window says "type here..." and if you click on any other page on the website the url in the browser window does not change.

  5. David Choi
    Member
    Posted 1 year ago #

    Visited your site with Chrome and Firefox, but I can't see any "type here..."

    If you can take a snapshot, that could be helpful

  6. rrglare
    Member
    Posted 1 year ago #

    This link will take you to a screenshot.

    http://divineprovinceminnesota.org/public_html/screenshot/

    You will note "Type here ..." on the window tab and Firefox url display (same with IE), and that the page URL is not complete. Whatever page you go to in the site is listed as http://www.divineprovinceminnesota.org. Thus it isn't possible to post page links directly from the site, with ease.

    Thank you for your kind assistance.

  7. rrglare
    Member
    Posted 1 year ago #

    The permalinks as designated do not show up in the browser

  8. David Choi
    Member
    Posted 1 year ago #

    That's totally unrelated to your site or WordPress. You are talking about Browser URL, therefore it's your Browser problem. Browsers have settings that you can hide or display the URL input bar.

  9. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    You have a problem with plugins/cafepress-widget. Rename that plugin to cafepress-widget-old. You can use ftp or sign in to your hosted site and use whatever file manager they have.

  10. rrglare
    Member
    Posted 1 year ago #

    Thanks, guys, I changed the Firefox browser setting to show full url, but it only added "http://". The "Type anything you want ..." remains, and would have to do with a WordPress template, I'm guessing. Also, the same problem shows up in Internet Explorer.

    I deleted cafepress plug-in because I'm not using it. No change. Perhaps that was the wrong approach . . .

  11. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Your site loads this

    <html>
    <head>
    <title> Type here anything you want </title> <!-- This text will be shown as name of the page -->
    </head>
    <frameset>
    <frame src="http://divineprovinceminnesota.org/public_html">
    </frameset>
    <noframes>Your browser does not support frames. Please click <a href="http://destination_domain.tld"> here </a> to be redirected automatically </noframes> <!-- This tag is required for old browsers. If browser does not support frames, end user will see a message indicated between <noframes>...</noframes> -->
    </html>

    Does that look familiar to you?

  12. rrglare
    Member
    Posted 1 year ago #

    "Type here anything you want" looks much too familiar to me. The rest I have not come across.

    Did I somehow get an old version of WordPress that uses frames? I thought I had the current version. Apologize that my programming knowledge is superficial.

  13. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    No, this is not coming from WordPress. WordPress does not use frames.

    Try deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    The bgi plugin uses an iframe so it might be in the settings for that.

  14. rrglare
    Member
    Posted 1 year ago #

    I was only using 7, I deactivated them. No change. I'm contemplating taking the site down and starting over, which is discouraging at this point.

  15. David Choi
    Member
    Posted 1 year ago #

    Using the Chrome browser, I've visited

    http://divineprovinceminnesota.org/

    but when I right clicked the mouse to see the "view source" it shows the content of

    http://divineprovinceminnesota.org/public_html/

    Maybe your site was called from a HTML FRAME? If you can take a snapshot of your site's structure after logging into FTP, that might give us clues.

  16. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    If the plugins are ruled out, change to the twentytwelve theme so we can rule out the theme.

    [edit] Sorry, you are using the correct theme.

  17. rrglare
    Member
    Posted 1 year ago #

  18. David Choi
    Member
    Posted 1 year ago #

    Nothing suspicious there, what about inside the "public_html" folder?

  19. rrglare
    Member
    Posted 1 year ago #

    Changing the theme did not make any difference. I'll leave it at 2012 so you can see, for a while.

  20. David Choi
    Member
    Posted 1 year ago #

    Checked your site, indeed it's the same, we can rule out the theme. Based on the bahvior, it should have the following structure:

    public_html/public_html

    a second "public_html" subfolder. If not, then contact your host to see if they can spot anything.

  21. rrglare
    Member
    Posted 1 year ago #

    Yes, it does have public_html/public_html as shown in the directory tree. However, I've been fttp-ing to the first level public_html. Is that a problem? Second level has the wp program files in it only

  22. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    This is not correct,
    http://divineprovinceminnesota.org/public_html/march-16-17-audios/

    Your structure should be public_html/and then a folder with your site. You should not be able to add any folders or files above public_html.

  23. David Choi
    Member
    Posted 1 year ago #

    Looks like the second public_html is created by accident, because it shouldn't be there. You can use FTP client like Filezilla or your hostings panel to move all the files up one level.

    Here are the instructions

    http://codex.wordpress.org/Moving_WordPress

    scroll down until the part

    "When Your Domain Name or URLs Change > On Your Existing Server"

    or you use a plugin like

    http://wordpress.org/extend/plugins/duplicator/

  24. rrglare
    Member
    Posted 1 year ago #

    With some assistance from my hosting company we have moved the site which has resolved the problem.

    Let me express my appreciation for your time and attention, I am grateful for resolution.

    Now when I can get the graphics to show I'll be good :)

  25. David Choi
    Member
    Posted 1 year ago #

    Glad they are moved. For the image, you probably have to do a search and replace in order to change image URLs in your posts, using a tool like

    http://interconnectit.com/products/search-and-replace-for-wordpress-databases/

    So you enter

    http://divineprovinceminnesota.org/public_html

    to replace with

    http://divineprovinceminnesota.org

    to reflect the new URL.

Topic Closed

This topic has been closed to new replies.

About this Topic