WordPress.org

Ready to get started?Download WordPress

Forums

TablePress
[resolved] Page slow to load with many individual tables (6 posts)

  1. dazmeister
    Member
    Posted 7 months ago #

    Hi Tobias,

    I read this article when searching for similar issues
    but unsure if the dev solution supplied would help? Being a running club we have many results published throughout the year and as the year draws to a close, we find the 'Results' page takes longer and longer to load until it is refreshed for the new year.
    The tables themselves are not large, maybe 8-10 rows max but over the period of a year we may have approx 500 individual tables listed on one results page.
    Is there a workaround perhaps to make the page load faster? It may not be the limitations of your great plugin but the back end infrastructure? I can supply a link to the results page if required. Or perhaps a suggestion on how to minimize the load.
    I guess another way would be to create a new Results page each month but the current way is done through ease of use (and habit).

    Thanks

    Darrin

    http://wordpress.org/plugins/tablepress/

  2. TobiasBg
    Member
    Plugin Author

    Posted 7 months ago #

    Hi,

    thanks for your post, and sorry for the trouble.

    The link you posted does apply more to issues in the backend/admin area, while your problems seem to happen on the frontend, when viewing the tables on a page.
    It would indeed be good if you post the URL to that "Results" page, so that I can take a look.

    My assumption is that this is affected by the number of tables. Loading and printing 500 tables just can take some time. Creating a new results page for every month sounds like a good approach therefore.

    Regards,
    Tobias

  3. dazmeister
    Member
    Posted 7 months ago #

    Thanks for prompt reply, here is the link to site...

    results

    I guess a different way of working is required.

  4. TobiasBg
    Member
    Plugin Author

    Posted 7 months ago #

    Hi,

    thanks for the link!

    I noticed another possibility there: You have enabled the usage of the DataTables JS library on all (or at least most) of the tables on that page. However, you have turned off the individual features (like sorting and filtering). Therefore, it would be worth a try to turn off DataTables for those tables entirely (by unchecking the "Use DataTables" checkbox on the "Edit" screen of each table there). That should speed up the loading because the JS does not have to be initialized.

    Regards,
    Tobias

  5. dazmeister
    Member
    Posted 7 months ago #

    Hi Tobias,

    Yes it appears we have (enabled DataTables). The problem I have is the role of results master is always revolving and I guess I have to remind Admin users of the importance of this field.
    Good time to re-educate being the start of the New Year soon as it will take me some time to visit every table from this past year to uncheck that option.

    Thanks again for your prompt response on the matter.

    After browsing the support forum I am looking forward to using your data-tables-row-details plugin later (once this is resolved) to enable live data on our runners. I will be sure to donate!

    Thanks

  6. TobiasBg
    Member
    Plugin Author

    Posted 7 months ago #

    Hi,

    yes, turning off that checkbox for all existing tables will be a little bit of work, but you can then also use the TablePress Extension from http://tablepress.org/extensions/datatables-off-new-tables/ to turn the checkbox off for all newly created tables then :-)

    Note that you will need DataTables enabled for the Row Details Extension then (but you can then enable it just for the tables that use that Extension).

    And thanks for wanting to donate, I really appreciate it!

    Best wishes,
    Tobias

    P.S.: In case you haven't, please rate TablePress here in the plugin directory. Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic