WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
page-sitemap.xml Error in Google Webmaster Tools (8 posts)

  1. gamehermit
    Member
    Posted 2 years ago #

    I hope this is an easy fix...

    I enabled sitemaps in the Yoast SEO plugin and successfully submitted the "sitemap_index.xml" sitemap. When I drill down into the site map these sitemaps have been submitted successfully:

    /category-sitemap.xml
    /post-sitemap.xml
    /category-sitemap.xml

    However, the "/page-sitemap.xml" sitemap has an "X" on it with the following error:

    Invalid URL
    This is not a valid URL. Please correct it and resubmit.

    Google also reports this information as well:

    URL:
    http://
    Parent tag: url
    Tag: loc
    Problem detected on: Aug 5, 2011

    The weird thing is that Webmaster Tools reports that 33 URLs have been submitted via the "page-sitemap.xml".

    Everything looks fine when I browse directly to the sitemap... Here's the URL:

    http://www.pumpkinlady.com/sitemap_index.xml

    Not sure what to do :)

    Thanks :)

  2. ehwh
    Member
    Posted 2 years ago #

    Hello gamehermit
    Did you find a solution? I'm having the same error message in Google's webmastertools

  3. fckdigital
    Member
    Posted 2 years ago #

    Are you sure this is the correct url, I get redirected but I see other sitemaps listed in your robots.txt file, there is at least one by yoost http://www.pumpkinlady.com/xml-sitemap.php but only contains 2 urls.

    I would, FTP to your site and check what files are actually on your server. if they are there I'd look for what is causing this 301 redirection possibly .htaccess?? you can see the redirection going on when you enter the url on http://www.seoconsultants.com/tools/headers

  4. ehwh
    Member
    Posted 2 years ago #

    Hello fckdigital,
    looking at your answer to the question of gamehermit, I thought it would be a good idea to post the link to my website sitemap here. Maybe you cabn see whats happening.
    In Google's webmastertools I'm gettin the same respons as gamehermit:
    URL:
    http://
    Parent tag: url
    Tag: loc
    Problem detected on: jan 10, 2012
    and the message: Line 22 Invalid URL etc.
    in this line its just <loc>#<loc> it seems to point to the sitemap itself

    url: http://www.a-rigaud.nl/page-sitemap.xml

  5. fckdigital
    Member
    Posted 2 years ago #

    Hi Ehwh

    OK well I don't think you have the same problem, I can see your sitemap, the sitemap index, the main file that points to other sitemaps is actually http://www.a-rigaud.nl/sitemap_index.xml which looks fine.

    Im guessing the problem is how you have submitted it to WMT. From site configuration > Sitemaps click submit a sitemap and only enter sitemap_index.xml. Hopefully after a few min a page refresh and you should see a green tick :)

    C

    PS a correction on my earlier post, these sitemaps aren't static files so you won't find them using FTP. Earlier issue might be clashing with another xml plugin

  6. ehwh
    Member
    Posted 2 years ago #

    Hi fckdigital,
    Thanks for your answer, you were right, I pointed to one of the sitemap xml files. After changing it,it works better. Although I don't see a green tick, just a clocksymbol. ( after 17 ours ) And I still have the same red cross for the /page-sitemap.xml in WMT with the error message now for line 16 with is <loc>#<loc>

  7. fckdigital
    Member
    Posted 2 years ago #

    glad you had some success,

    The the error, I'd check through your pages, the script just make a sitemap of the pages you have on your system, if you had something odd in there like the # on the 3rd line I'd try to get rid of it from your system.

  8. ehwh
    Member
    Posted 2 years ago #

    oké, found it.
    The problem was I didn't look beyond my nose....: I used some pages as placeholders in the menu ( option in the theme I am using , weaver II pro ) in combination with the ( great )Yoast SEO wordpress plugin. In the seo plugin it was necessary to change in the advanced options: index to no index, follow to no follow and "never insert" in the "insert in Sitemap" option.
    That did the job, I now have a nice sitemap!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic