WordPress.org

Ready to get started?Download WordPress

Forums

Hueman
Page Options>Layout is not overriding the defaul (8 posts)

  1. agershon
    Member
    Posted 3 months ago #

    My default page layout is "left sidebar|body|right sidebar". On one of my pages, I'd like to have only the left sidebar. I'm choosing the alternative page layout under the Page Options section, but it's not changing anything.

    See this page: http://www.fastinfastout.com/track-days-calendar/

    What am I missing about overriding the page layout default?

    Thanks,
    Adam.

  2. Alexander Agnarson
    Member
    Theme Author

    Posted 3 months ago #

    Hi Adam! That sounds strange.

    If you go to Theme Options > Layout > Default Page and set it to (X), does your individual page option start to work?

  3. agershon
    Member
    Posted 3 months ago #

    Hey Alexander ... appreciate your quick response. And the theme is awesome.

    The only option that is NOT (X) on that page is Global Layout. All the individual page types are (X).

  4. agershon
    Member
    Posted 3 months ago #

    Alexandar ... FYI there's a conflict with The Event Calendar plugin. Alternative layouts don't work on the Events page, but they work perfectly well on every other page.

    Not sure if you can provide any guidance on working with The Event Calendar.

  5. Alexander Agnarson
    Member
    Theme Author

    Posted 3 months ago #

    Thanks for the update, I had no idea what was going on there.

    I think the Event Calendar plugin may be using archive pages, so to adjust the general layout for it, try going to Theme Options > Layout > Archive and see if it changes if you change there.

  6. agershon
    Member
    Posted 3 months ago #

    Thanks Alex.

    So, I changed my Global Layout to 1 right column, and now the Calendar page follows this layout: http://www.fastinfastout.com/track-days-calendar/

    Then, I just use the layout choices for the other pages however I want. Seems to work! Thanks for your input.

    NOW, only problems left is that the meta-title is just "Events", meta-description is blank, and the H2 shows the next upcoming event title. I've tried a lot of CSS fixes by I can't fix these bugs :(

  7. Alexander Agnarson
    Member
    Theme Author

    Posted 3 months ago #

    You want to just hide the page title completely? Like:

    .events-gridview .page-title,
    .events-archive .page-title { display: none; }
  8. agershon
    Member
    Posted 3 months ago #

    Brilliant!!!!

    Any ideas for meta-title and meta-description??

    A donation is coming your way for sure :)

Reply

You must log in to post.

About this Theme

About this Topic