WordPress.org

Ready to get started?Download WordPress

Forums

Page not found and too many redirects errors (7 posts)

  1. WordpMoon12
    Member
    Posted 1 year ago #

    My frontend sometimes doesn't load properly; sometimes the images won't show up, and sometimes it seems like the CSS doesn't load at all.
    And this happens quite randomly.
    Also when I try to login to my backend (wp-admin) I sometimes get Page Not Found and sometimes 301 Too Many Redirects errors. After refreshing the page few times I am able to login but then the problem happens again when using the backend.

    I tried to disable some plugins to see if the problem has something to do with the plugins but no luck yet.
    I also checked my .HTACCESS file on the root folder and I found many duplicates of

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    And what is also happening is that the HTACCESS filesize seems to be changing, it is getting sometimes smaller and sometimes bigger.
    Apparently the HTACCESS file keeps changing and duplicating the same Rewrite Rule.

    Any ideas why all this is happening, why this is happening or is it because my WordPress has been hacked??

  2. Treebeard
    Member
    Posted 1 year ago #

    This sounds like a problem I had a while back when I tried using Better WP Security, did you ever install that plugin? When I deleted the plugin, the settings remained in the database and I had to delete all those tables manually to stop this from happening.

  3. WordpMoon12
    Member
    Posted 1 year ago #

    Hmmm, I don't remember ever installing Better WP Security to my WordPress.
    But if there are tables, where can I find them on my database?

  4. Treebeard
    Member
    Posted 1 year ago #

    Maybe it was Bullet Proof Security, does that sound familiar?

  5. WordpMoon12
    Member
    Posted 1 year ago #

    I think the problem is not with the security plugins, since I haven't found related folders or files on my WP installation.

    I noticed that if clear my browser cookies and history, my homepage starts loading like it is suppose to (and everything is fine).
    It's only sometimes that the page stops loading CSS and images and then I need to clear the browser again.
    Could it be some internal WP cache issue?

  6. Treebeard
    Member
    Posted 1 year ago #

    It's not usually a problem within WP, it could be one of your plugins, or perhaps one that you installed to try and deleted at some point (they sometimes leave residual code behind even after being deleted) but it's hard to say without seeing the files. This behavior is definitely not a typical issue with WP though.

    Sounds like you really need to do some troubleshooting though. I would dig deeper into the plugins and also check the database to see if there's something left over from a previous plugin. Maybe something like WP Cache or something similar. I would also check your hosting setup, it could be something going on with the server - might want to just make a quick call and see if tech support can find anything.

  7. WordpMoon12
    Member
    Posted 1 year ago #

    Thanks,
    I was sure that the problem had something to do with the W3 Total Cache.
    That I had installed before.
    However, uninstalling it "the proper way" didn't help as well.
    And at the end clearing my browser cache didn't help either.

    I will try to contact the tech support next=)

    I am also still wondering what's going on with the .htaccess file.
    The file size keeps jumping between 100,000 and 700,000 bytes.
    And when I open the htaccess file, I see the same rewrite rule several times.

Topic Closed

This topic has been closed to new replies.

About this Topic