WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Page not displaying when link added (9 posts)

  1. pagey
    Member
    Posted 6 years ago #

    Hi there,

    I have recently started using WordPress, and am loving it so far.

    I'm having an issue with some pages. I only want them to be accessible via one of my menu items, and don't want them displayed in the menu themselves. I had this working fine, until I added several links on each of these pages. The links were going to go onto other pages which also wouldn't be accessible via the main menu.

    For some reason, the pages are no longer displaying, although the page id is exactly the same. The only way I can get them to display is by publishing them, and then they show up in the main menu, which I don't want.

    Any help would be very much appreciated. You can check the site out if you like at http://www.swanseatabletennis.co.uk. Its the 'Premier, Divisions 1, 2 and 3 that I want to be only accessible via the Divisions button of the menu.

    Cheers

  2. MichaelH
    Member
    Posted 6 years ago #

    That theme, Peaceful Rush, uses the template tag, wp_list_pages(), so you could use the exclude or include parameter to achieve your results.

    You've probably changed the code to print Menu instead of Pages, so just add the appropriate parameter that works for you (include is probably the way to go).

  3. pagey
    Member
    Posted 6 years ago #

    Thanks for the speedy response!

    Now I just need to figure how the hell to to what you've told me to do!

  4. pagey
    Member
    Posted 6 years ago #

    Could anybody help me implement these changes that Michael has suggested?

  5. MichaelH
    Member
    Posted 6 years ago #

    Well I'll start with one question. Did you change your theme's sidebar.php file to display the word "Menu" over your Page links (About, Divisions, ...Gallery etc)?

  6. pagey
    Member
    Posted 6 years ago #

    Not to my knowledge....

  7. pagey
    Member
    Posted 6 years ago #

    Come on Michael, don't tease me...!

  8. MichaelH
    Member
    Posted 6 years ago #

    Okay, then you must be using Widgets.

    If so, then in the Pages widget, just add the Pages you want excluded into the Exclude box on that widget's configuration. If you want pages 5,7, and 8 excluded enter 5,7,8 in that box.

  9. pagey
    Member
    Posted 6 years ago #

    You Sir, are a genius.

    Thank you so much for you patience with a rookie like me.

    You're very kind.

Topic Closed

This topic has been closed to new replies.

About this Topic