WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Page not displaying content (12 posts)

  1. NovaCaine
    Member
    Posted 8 years ago #

    Hey all,

    First off, I'm new to WordPress and blogs. My problem is one of my pages doesn't display its content. This page (http://www.novacaine-industries.com/portfolio/cv/) shoud read :

    This will be where my C.V. resides

    Now to give you all some insight on how i created this page. First i created a page called Portfolio, then created the CV page as a child of the portfolio page.

    Did i do something wrong? What code(if any) should i post?

    Sorry if this may have been asked before, but my search returned nothing relevant.

    Thanks in advance.

    EDIT: Just had a bit of a play around, the content will show fine if it's not a child of my portfolio page. What may cause this?

  2. nearlythere
    Member
    Posted 8 years ago #

    i just noticed when i go to your site, then click on the CV page, and rollover the 'edit' link i see no post ID.
    http://novacaine-industries.com/wp-admin/post.php?action=edit&post=

    whereas in my own site, i see a post ID at the end of the edit link like:
    ... wp-admin/post.php?action=edit&post=74

    did you try editing from that link?

  3. NovaCaine
    Member
    Posted 8 years ago #

    No, i created the page thru the WordPress interface (Add Page). but that is very odd.

    Ahh in fact (i probably should have tried this sooner) if i change my theme back to the default one (Kubrick?) i get a 404 error. Any ideas?

    EDIT: Still having a play around. Seems that the page isn't located at /portfolio/cv but is at /cv/. is this a problem with my permalinks? they are currently set up for /%pagename%. Should this be something like /%pagename%/%pagename%?

    EDIT: Ok, think i may have fixed it now. Seems that i needed to set my permalink structure to /%pagename%/%pagename%. Do i need to do this for as deep as i want child pages in this kind of setup?

  4. moshu
    Member
    Posted 8 years ago #

    Is your .htaccess file writable? Using nice permalinks you have to have it always writable when creating a new Page.

  5. NovaCaine
    Member
    Posted 8 years ago #

    Well it is now, i used to have to edit it manually.

  6. moshu
    Member
    Posted 8 years ago #

    You don't have to use %pagename% - that's not even a valid tag for permalinks.

  7. NovaCaine
    Member
    Posted 8 years ago #

    It seems to work, what i'm wanting is the page name to follow my domain name( i.e http://www.novacaine-industries.com/portfolio etc). which tags would i use? are pages considered as posts?

  8. moshu
    Member
    Posted 8 years ago #

    Here are the tags you can use: Using_Permalinks

  9. NovaCaine
    Member
    Posted 8 years ago #

    i've read that, but it doesn't answer my question. I've now removed my permalink structure, but when i list children pages i get the ?page_id=9 instead of /portfolio/cv/ which is what i'm trying to setup. Could you point me in the right direction of how to do this?

  10. Xyth
    Member
    Posted 8 years ago #

    Under your options/permalinks tab, set your structure to

    /%postname%/

    That seems to work for me. Make sure you set your htaccess file to writable (666) before making this change.

  11. NovaCaine
    Member
    Posted 8 years ago #

    Will try, but just for me to understand, are pages treated as posts?

    EDIT: Sweet! It appears to be working exactly as i was hoping for. Cheers again for all the help guys.

  12. Berko
    Member
    Posted 8 years ago #

    I am having this problem, too, but changing my permalinks to /%postname%/ didn't fix it. The only thing that I think I may have done differently is that I have excluded page 77 (the problem page) from my wp_list_pages call in the sidebar. The page works fine when I don't have permalinks turned on, but when I turn them on [siteurl]/ grandparentpage/parentpage/page/ gives me a 404. Here is the problem URL: http://www.jamiephelps.com/saintpeter/articles/listarticles/believe/ If I move the page to be a child of articles, it displays fine. But I don't want my full list of articles to show on the front page, so I created a "container" page as a child of "articles", made all the articles children of the container page and excluded the container page from my wp_list_pages(); function. Anyone see problems with that?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags