WordPress.org

Ready to get started?Download WordPress

Forums

Page Nav links at bottom of Home - disappear with custom theme (1 post)

  1. PaulieP
    Member
    Posted 4 years ago #

    So I had a custom theme made for my site and the designer has since gone MIA so I figured someone here could maybe help.

    Basically the page navigation links for Previous/Older Posts etc. that normally appear at the bottom of the home page are not showing up. it appears that the code is there, but something about the theme prevents those links from appearing.

    below is the existing code from the custom theme's index.php, containing the nav link code in what appears to be the usual place. HOwever nothing shows. I have tried replacing the code with the common numbered page navigation that a lot of people use, but that also does nothing - so I'm pretty sure there's something with the theme that I'm missing, that's keeping the nav links from showing at all.

    Any input appreciated. Thanks.

    Code from theme index.php:

    <?php get_header(); ?>
    <!-- Begin #container3 keeps left col and body positioned-->
    <div id="container3">
    <?php get_sidebar(); ?>
    <!-- Begin #content -->
    <div id="content">

    <?php if (have_posts()) : ?>
    <?php while (have_posts()) : the_post(); ?>
    <div class="postMain png"><!-- Post Block Wrapper -->
    <div class="post"><!-- Post Contents -->
    <h2>" title="Permanent Link to <?php the_title_attribute(); ?>"><?php the_title(); ?></h2>
    <h3><?php the_time('F jS, Y') ?> | By <?php the_author() ?></h3>

    <?php if(get_post_meta($post->ID, "thumbnail", true)) {
    $size = getimagesize(get_post_meta($post->ID, "thumbnail", true)); ?>
    " title="<?php the_title(); ?>"><img src="<?php echo get_post_meta($post->ID, "thumbnail", true); ?>" alt="<?php the_title(); ?>" width="<?php echo $size[0]; ?>" height="<?php echo $size[1]; ?>" class="alignleft" />
    <?php } ?>

    <?php the_content(); ?>
    <div class="postMeta"><?php the_tags('Tags: ', ', ', '
    '); ?> Posted in <?php the_category(', ') ?>
    Comments: <?php comments_popup_link('No Comments »', '1 Comment »', '% Comments »'); ?></div>
    </div><!-- / Post Contents End -->
    </div><!-- / Post Block Wrapper End -->
    <div class="clr"><!-- --></div>
    <div class="postFoot png"><!-- --></div><!-- / Post Footer for image -->
    <?php endwhile; ?>
    <?php else : ?>
    <?php endif; ?>

    </div><!--//content -->
    </div><!--//container3 -->

    <div class="navigation">
    <div class="alignleft"><?php next_posts_link('« Older Entries') ?></div>
    <div class="alignright"><?php previous_posts_link('Newer Entries »') ?></div>
    </div>

    <?php include (TEMPLATEPATH . "/sidebarRT.php"); ?>
    <?php get_footer(); ?>

Topic Closed

This topic has been closed to new replies.

About this Topic