WordPress.org

Ready to get started?Download WordPress

Forums

page looks fine on lan but looks like text outside it (10 posts)

  1. noworky
    Member
    Posted 2 years ago #

    I can not get my page to show up correctly outside of my LAN. I can not figure out what the general settings are supposed to be. 2008r2 php5.3 The setup worked flawlessly.. I'm about to give up... please help

    http://www.erfd.org

  2. ClaytonJames
    Member
    Posted 2 years ago #

    You installed WordPress using an internal private IP address of 192.168.1.200. It needs to be changed to your actual domain name to be accessible from the WAN.

  3. noworky
    Member
    Posted 2 years ago #

    ok, so which URL do I change? WordPress Address (URL) or Site Address (URL)... once i change it.. it becomes unreadable and i have to start over again.. My Wan address from my isp??

  4. noworky
    Member
    Posted 2 years ago #

    Now i'm getting the white screen of death and can not change settings again..

  5. ClaytonJames
    Member
    Posted 2 years ago #

    ok, so which URL do I change?

    Both

    once i change it.. it becomes unreadable and i have to start over again.

    Once you do that, for all practical purposes, you can no longer access it from the LAN using the internal private ip address. Access it using the domain name.

    My Wan address from my isp??

    Nope. Not a numeric address. Your actual domain name. http://www.erfd.org

    Your domain name needs to resolve to your static server ip address. If you don't have a static ip address, and are using a residential account that dynamically re-assigns ip addresses on a regular basis, you're going to have issues with the site going down every time your isp gives you a new address.

  6. ClaytonJames
    Member
    Posted 2 years ago #

    Your site also seems to be framed for some reason. In that source I'm seeing your wan ip address. When I click on what should be a link to your themes style sheet, it just loops me right back to this.

    //184.74.116.233//wp-content/themes/twentyeleven

  7. noworky
    Member
    Posted 2 years ago #

    My domain name does resolve to my Static address 184.74.116.233. Inside my sonic wall it's then forwarded to this server (192.168.1.200) also static.. I'm not getting the wonderful theme attributes outside the lan.. I don't know what to do next!!

  8. ClaytonJames
    Member
    Posted 2 years ago #

    The blog addresses look okay. I can see the domain name now but this is the actual path to your style sheet, as it appears in the source. It has your ip address instead of the domain name.

    http://184.74.116.233//wp-content/themes/twentyeleven/style.css

    Is there a reason why WordPress is being served from an frame instead of directly from the index.php file in the directory root? ( note the extra slash in that address, as well )

  9. noworky
    Member
    Posted 2 years ago #

    I wish i could give you a good answer. it makes no sense to me either. i'm ready to give up and pay someone to install this correctly..

  10. noworky
    Member
    Posted 2 years ago #

    I have my iis7 document pointed to index.php

Topic Closed

This topic has been closed to new replies.

About this Topic