WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Page links in navigation don't work (8 posts)

  1. heycats
    Member
    Posted 1 year ago #

    I have set up a new site and I'm using the IP address for development since we want to build the site first before we transfer the domain name from the old site. My problem is that I've created several pages and when I try to visit the page from the navigation structure I get the "Not Found" error. Here is the IP address of the beta site:

    http://66.193.47.57/

    I've installed all the WP code in the root directory.

    Any ideas why these links don't work? Any help would be greatly appreciated! Thanks in advance.

    Carol

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    What happens if you use the default permalink structure?

  3. heycats
    Member
    Posted 1 year ago #

    It works just fine. What's up with that? I don't want to use that when we go live. But it's fine for development. Thanks! At least I can proceed.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Was the root .htaccess file updated correctly?

  5. heycats
    Member
    Posted 1 year ago #

    Well, I didn't make any changes to the file. I installed the site using scripts provided by the host. Here it is:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase //
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Is something missing here? Thanks!

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    Check with your hosts that mod_rewrite is running on your server.

  7. heycats
    Member
    Posted 1 year ago #

    Okay, I got it fixed - thanks for pointing me in the right direction!! The scripts installed the .htaccess file as .htaccess.ss. So I just renamed it correctly and all works great. Doh!

  8. tms21
    Member
    Posted 1 year ago #

    i had the same problem

    put your permalinks settings on standard

Topic Closed

This topic has been closed to new replies.

About this Topic