WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Page links broken after DNS transfer and WP upgrade (3 posts)

  1. monjela
    Member
    Posted 2 years ago #

    Hi,

    After changing hosts and DNS, installing the latest WP and then importing the database as .sql file via phpMyAdmin I have the homepage looking like it's pretty much all there, minus some CSS, but none of the page links work. I get a "404 page not found error" message.

    http://www.abundantia.com.au/

    From within the Admin panel I can see the pages and all the content, so I know it's in the database.

    I searched for support forums and found some info regarding do a search and replace in the database but am unsure of "what" to search for and what to replace. I've had a quick look in the database and there was only reference to the old host I found was replaced with the new one, but that wasn't the answer.

    I can make new pages, so it's something to do with the old paths but I don't understand how they work in WP or where to find them to see the broken links.

    Any help would be greatly appreciated.

  2. s_ha_dum
    Member
    Posted 2 years ago #

    You are trying to use 'pretty permalinks' which depends upon, ideally, the Apache web server's mod_rewrite module and a .htaccess file. You've moved your site a Zeus web server. WordPress and the web server don't know how to deal with your URLs. I haven't ever dealt with a Zeus server but perhaps this page will help.

  3. monjela
    Member
    Posted 2 years ago #

    Thank-you so much!

    Although following the instructions on that page did not work. Creating a new file named "rewrite.script" and placing in the root folder had no effect.

    However, following a link from the site you suggested I did find further instructions on this page which did the trick - specifically for Netregistry and noobies like me.

    Reading down through the comments I found these instructions:

    1. Log in to your console
    2. Select "administer domain"
    3. Select "webhosting"
    4. Enable "Request rewrite support" under webserver options
    5. Paste code into text block and click "change"

    That worked.

Topic Closed

This topic has been closed to new replies.

About this Topic