WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Page link stopped working (10 posts)

  1. wisefool
    Member
    Posted 1 year ago #

    So a site I helped develop utilizing WP was working perfectly for about two months. Seemingly on it's own, one of the links in the menubar stopped working.

    If you visit http://www.bdingredients.com and click the 'News & Events' link in the menu bar you'll see that it displays the home page again. It should be taking you to a different page (the blog section of the site, actually) but doesn't any longer. The template for the page is in place, the menubar link is a page and not a post so the permalink shouldn't be an issue (or is it?) and what's most frustrating is that it was working before, even though the url in my browser address bar does reflect the correct page.

    This happened seemingly on its own. I see no blog posts or edited pages since I touched the site. I feel like I'm missing something obvious but don't know what. I did backup everything and update everything and still it's a problem.

    Thanks.

  2. govpatel
    Member
    Posted 1 year ago #

    In Settings>>>>Reading check what page you have as post page.

  3. wisefool
    Member
    Posted 1 year ago #

    Hi govpatel,

    In the settings > reading > post page is set to News & Events

  4. Doodlebee
    Member
    Posted 1 year ago #

    This happened seemingly on its own. I see no blog posts or edited pages since I touched the site. I feel like I'm missing something obvious but don't know what.

    When questions start out like this (or "it just suddenly satrted doing...") you need to look at recent events. Did someone just upgrade plugins? Add new ones? Any alterations to the .htaccess files recently? Has the *host* done anything to the servers?

    In the settings > reading > post page is set to News & Events

    and how about the "Home" page? When you set a page for the blog posts, you also have to set a page as "home" (unless you have the thing set as "your latest posts" instead of "A static page")

    You have a category called "news" and one called "events" - but do you actually have one called "news-events"? (i.e. http://www.bdingredients.com/category/news/) Could be that someone just messed with the nav menu, and linked to a page that doesn't exist, or the News & Events Page doens't have the correct template file set to it.

  5. wisefool
    Member
    Posted 1 year ago #

    Hi Shelly,

    When I logged in today, the WP 3.4.1 upgrade along with four plugins were all waiting to be updated. Before upgrading WP, I did try de-activating the plugins that were ready to be updated one-by-one. I backed everything up and then one-by-one, starting with WP, upgraded everything. No change.

    As far as the 'Home' page, I am seeing something peculiar; The radio button is set to 'a static page' but the front page isn't selected, it's drop down menu is still at '- Select -' apparently the developer who started this project edited index.php template to create the home page. I know that is not the ideal way to do things but I can't fault it as it's worked that way for about four months without a problem.

    I did confirm that there is a News & Events page and it is pulling the right template (news-events.php) and that the template page is actually written to query posts from all (two) categories. The pages exist and the templates appear to be correct and what's so frustrating is that it was all working fine when I last looked at it.

    Thanks.

  6. Doodlebee
    Member
    Posted 1 year ago #

    >>I did confirm that there is a News & Events page <<

    What's the slug? And is there any other page (or category, or custom post type) that has the same slug?

  7. wisefool
    Member
    Posted 1 year ago #

    The slug is /news-events/

    Nothing else contains that slug.

  8. Doodlebee
    Member
    Posted 1 year ago #

    How very strange. Have you tried re-saving your permalinks (or reverting to default)?

  9. wisefool
    Member
    Posted 1 year ago #

    A friend suggest re-saving the permalinks; no luck. I have no idea how to revert a permalink, but your suggestion inspired the idea of re-creating the whole page, which seems to now work.

    Thanks again!

  10. Doodlebee
    Member
    Posted 1 year ago #

    Glad you got it sorted. (as for reverting, you go to "Settings > Permalinks" and just choose "default" and save. Then see if the page works. ten go back and change the permalinks back to "custom" and save again. Sometimes that helps.)

Topic Closed

This topic has been closed to new replies.

About this Topic