WordPress.org

Ready to get started?Download WordPress

Forums

Page link only works sometimes (3 posts)

  1. kiltedfire1
    Member
    Posted 1 year ago #

    So, I am posting out of sheer frustration of not being able to find an answer that works from two different forums.

    I have a page link that is not working and I can't figure out why. When clicked, it acts like it is refreshing the current visible page, not even a 404 comes up. Yet if I click two other pages and then come back, it finally works.

    I noticed that when clicked, the URL page ID does not come up, just a /#. This resolves itself when clicking back to the page as described above with a proper page (/Start Here).

    The site in question is http://www.tlcestateauctions.com. The page link causing problems is Start Here.

    If anyone has any ideas to help with this issue, I would be very grateful.

    By the way, this issue is on a premium theme that came free with the software I purchased. Unfortunately, the software site does not support this theme and the company who does support it requires a paid subscription in order to post there.

  2. ricoh
    Member
    Posted 1 year ago #

    The link on the page is just showing a hash, working as a placeholder for an actual link (probably because it interacts with some javascript to show a sub menu when you hover). You may be able to go to appearance -> menus and replace that link with "/start-here". If you aren't able to do that, you will have to look through the theme code files to see what is responsible for outputting the following markup on the page

    <a href="#" class="sf-with-ul">Start Here<span class="sf-sub-indicator"> »</span></a>

    And change it so it outputs

    <a href="/start-here" class="sf-with-ul">Start Here<span class="sf-sub-indicator"> »</span></a>
  3. kiltedfire1
    Member
    Posted 1 year ago #

    Thanks for the response and tips. Unfortunately, I have not had a lot of time to spend on this issue so far today. Perhaps this evening I can delve a bit deeper.

    I still have not resolved this issue but taking your advice, I have scanned as many files as I can through both the hosting file manager and the editor in the WP dashboard. So far, I can't find the location of this code in order to change it.

    I used the inspect element feature on the page link through the site itself and see exactly what you found but I don't know how to find the file location except to look through all of them everywhere I can.

    I even pasted that string in the file search but nothing came up. Does anyone have any advice on a better way to find where I need to go?

    In the mean time, I'll just keep looking but thank you for your response so far.

    Oh, and I am guessing that it will be related JS since the link in question opens a drop down menu? Each of those links go where they are supposed to but perhaps the Start Here link is not supposed to go anywhere when clicked?

Topic Closed

This topic has been closed to new replies.

About this Topic