WordPress.org

Ready to get started?Download WordPress

Forums

Sidebar Login
Page does not refresh after login (17 posts)

  1. the beat
    Member
    Posted 11 months ago #

    After login using the Sidebar Login, I need to either refresh the page or navigate to another page before it will recognize the successful login. The form submission obviously does not initiate the DOM to be reloaded. I've noticed this has been an issue for others in the past, but have not found a fix.

    http://wordpress.org/plugins/sidebar-login/

  2. Man2u2uk
    Member
    Posted 11 months ago #

    I'm having exactly the same issue as well since the update the other day.

  3. Man2u2uk
    Member
    Posted 11 months ago #

    You still getting this issue "the beat"?

  4. jpavly
    Member
    Posted 11 months ago #

    I have the same issue on my site: http://www.freesoft.gr/

    I recently installed W3 Total Cache, maybe it has something to do, I'll disable it to check.

  5. Man2u2uk
    Member
    Posted 11 months ago #

    I also have installed W3 total cache recently as well.

  6. Man2u2uk
    Member
    Posted 11 months ago #

    I disabled W3 Total Cache last night and it made no difference.

    Sidebar Logon is still intermittently working.

  7. the beat
    Member
    Posted 11 months ago #

    I think W3TC was my problem. I deactivated page caching and it seems to work now...

  8. tapeasy
    Member
    Posted 10 months ago #

    I'm experiencing the same problem of login widget area not refreshing after a successful login. I do use W3 Total Cache, but I don't want to diasble the whole caching plugin simply to make this work. Is there any other way of refreshing the widget or the whole page after login? Please and thank you. :)

  9. mykee
    Member
    Posted 10 months ago #

    I have same problem. Older versions worked, but now no. I need CTRL+F5 for logged status. :-(
    I don't use W3TC on my site, and no any cache manager, but this login not working. I will search other widget if this will not correctly.
    Tried install, enable, then disable and uninstall W3TC, but not solved my problem. :-(
    I use Custom Login widget instead of this, sorry.

  10. perkypixel
    Member
    Posted 8 months ago #

    I am having the same issue with and without cache turned on.

    Anyone find a solution yet?

  11. db9429
    Member
    Posted 8 months ago #

    Same issue, with W3TC (but also same issue when the plugin is completely disabled)...

    Wow, I'm almost glad (sorry guys and girls) that it's not just me!

  12. spookeros
    Member
    Posted 7 months ago #

    I have the same issue after upgrading to wordpress 3.7.1

  13. jralston
    Member
    Posted 7 months ago #

    Having the same issue - on a main page login code I added. Need to force hard refresh and then it'll show the content it's supposed to. Anyone have suggestions? Not using caching.

  14. mortydot
    Member
    Posted 6 months ago #

    The problem is inside the way this plug-in redirects login pages. This reaction gives a small, but ugly fix.

    Problem
    If you leaf the option for the 'wich page' to redirect to empty, your browser thinks it loads the same page, and so uses its own cache. But we leaf this option empty in the widget to redirect to current page.

    If you change this option from empty to a fixed page, the sidebar login works. But there by, leaving a important option, and main feature of this widget unable to use.

    Fast ugly fix
    Use another page (e.g.: /) to redirect to in the widget option.

    Author fix suggestion
    Make sure that when you redirect to the current page, you give the browser/header the option to force new page. Also you can add a variable in the GET header with a random number to make sure caching doesn't match the url, and the browser thinks it needs to get a new page.

  15. mortydot
    Member
    Posted 6 months ago #

    Fix for us:

    Open sidebar-login.php
    Add on line 126 (above $secure_cookie and bellow $redirect_to on a new line:

    //cheks if ? already excists in url
    if (strpos($redirect_to,'?') !== false) {
    $redirect_to .= "&random_cach_fix=".rand(1,999999999999);
    } else {
    $redirect_to .= "?random_cach_fix=".rand(1,999999999999);
    }

    This works for us.

  16. Brad Smith
    Member
    Posted 5 months ago #

    Hey Mortydot thanks for posting this fix. Very much appreciated.

    Is there a way to cycle back to a clean url?
    Not appended with "/?random_cach_fix=414272794612"

    Do you know if a fix will be incorporated into a future plugin update?

  17. mortydot
    Member
    Posted 5 months ago #

    @brad, no the reason why this works is because of the ugly url.

    I also dont have any direct contact with the developer. But i'm sure he is reading this topic.

    The fix given in this topic is not a perment, good or clean fix. But it works.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.