WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Page Displays Off Center (8 posts)

  1. BVLogan
    Member
    Posted 4 years ago #

    I've just started with WordPress and having a problem with my initial attempts to post.

    Just as a test, I uploaded an image to my first post; no text, just an image. Upload goes fine.

    However, when I launch the site to see what it looks like, the image is skewed way to the right of the post's window. However, if I click on the image, the whole page resizes and the image is correctly scaled to fit in the post's window. This blog is intended to be one focusing on photography and I anticipate that every post will prominently feature a main image leading off the text.

    The link to the launch of the page is:

    http://www.innerglowstudios.net/Blog/

    Clicking on the image results in this display:

    http://www.innerglowstudios.net/Blog/2010/02/15/hello-world/the-sound-001-2-lg-sepia-sm/

    I am using:
    WordPress ver. 2.9.2
    Theme: Suffusion ver. 3.4.6 (Although the same behaviou occurs with every other (6 total) that I have tried.
    IE 8
    Image size: 800x629 pixels

    Can someone point me in the right direction that will make the initial page launch more closely resemble the second link referenced above.

    Thanks

  2. armstead
    Member
    Posted 4 years ago #

    You are posting a thumbnail on the page, instead of the image.

    First, make sure on the "single post" and "single page" option in the Suffusion menu is turned OFF.

    Then, if you are using the media Uploader edit the post again. Delete that one and reupload it, and then look at the bottom of the uploader and choose size you want. Usually it offers a medium size and a full size, depending on how biog your image is.

    Hope that helps.

  3. Mark / t31os
    Moderator
    Posted 4 years ago #

    The div element that holds the image has some inline styling which is causing the display issue..

    style="width: 810px"

    Open the post, see if it's present and if so, remove it.. that should hopefully fix the issue, assuming you want to keep the image as is..

  4. armstead
    Member
    Posted 4 years ago #

    Or.....

    If what you really want on the front page is the smaller thumbnail, disregard the above, and on friont page options choose "excerpt only" and show thumb on the Front Page.

    Basically it looks like you are getting the full zize inage on the front and a thumbnail.

    If I were you and don't have a lot of pictires yet, I would delete the photo, reupload it and only show a thumbnail on the post/page.

  5. armstead
    Member
    Posted 4 years ago #

    The "disragard above" was referring to my post...Unfortunate timing of posts there. ;)

  6. Mark / t31os
    Moderator
    Posted 4 years ago #

    No problem with me, the more suggestions the merrier... ;)

    NOTE: You can edit you posts within the first 30-60 minutes of posting a response.

  7. BVLogan
    Member
    Posted 4 years ago #

    Many thanks to all.

    t31os_: Did not find the div element you mentioned.

    Armstead: I cannot find the "single post" and "single page" options in the Suffusion menu. Perhaps its not in my version?

    I did delete the photo and reuploaded it, selecting the "full size" option and it displays at the right size and right position correctly now. However, clicking on the images still causes a reduction in the page size of the blog, along with a thumbnail in the post box. Is this by design? If so, is there a way to disable it?

  8. Mark / t31os
    Moderator
    Posted 4 years ago #

    When you insert an image you are given three options for where it links to, the page you're referring to is the attachment's own page(every attachment has one), if you do not want it to link there, choose one of the other options when inserting it into the post.

    :)

Topic Closed

This topic has been closed to new replies.

About this Topic