WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Page displays content correctly, but editor and database thinks it has 0 words (3 posts)

  1. lovingboth
    Member
    Posted 1 year ago #

    A site I am responsible for is correctly displaying text (and a picture) on its home page (set up via Settings / Reading / Front page displays / Static).

    However when I try to edit the page in the editor, it reckons it is blank and contains zero words, whether I use the HTML editor or visual editor.

    All the other pages and posts on the site display correctly.

    Doing a MySQL 'CHECK TABLE' on the various tables reveals no problems, but if I look at wp_posts, the record with the revelant ID does have a post status of 'publish' and contains no text... yet as I say it displays correctly.

    There are records, with the post status of inherit, which do have the text that displays: the page has been edited successfully several times in the past. However if I compare revisions, WP reckons they are all identical, i.e. empty.

    I am wondering if there is some database corruption involving the bit of WP that displays pages thinking the relevant ID is - say - 15, but that the rest of WP reckons it is - say - 16.

    Suggestions welcome. At the moment, I am being tempted to copy the correct text into record that the editor thinks is the page, but if there is some corruption, I don't want to make things worse.

    Is there something that checks the content of the database for internal consistency?

  2. lovingboth
    Member
    Posted 1 year ago #

    Oh, it's probably worth adding that there is no WP cache plugin involved.

  3. lovingboth
    Member
    Posted 1 year ago #

    Ah ha, someone had put the front page text in a template, in order to try and stop the end user editing it and messing it up.

Topic Closed

This topic has been closed to new replies.

About this Topic