WordPress.org

Ready to get started?Download WordPress

Forums

Page Content Showing, But Not Blog Posts (4 posts)

  1. saramw09
    Member
    Posted 4 years ago #

    Hi all,

    I have a very urgent problem. Client just dumped a template on me saying it was a theme only needing minor adjustments, but it had NO WordPress code in it at all. *facepalm* Anyway, I got most everything working to satisfaction, but I ran into a problem I never had before. The blog content is not showing! I have the same exact code running the pages, and the page content is showing just fine. Furthermore, posts show just fine in the sidebar (using the "Sideblog" plug-in).

    Here is the code:

    <?php get_header(); ?>
        <?php include (TEMPLATEPATH . '/slideshow.php'); ?>
        <div id="left">
    		<div class="interior-content">
    		<?php if (have_posts()) : ?>
    			<?php while (have_posts()) : the_post(); ?>
            	<h2><a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title_attribute(); ?>"><?php the_title(); ?></a></h2>
    
    		<?php the_content(); ?>      
    
    		<?php endwhile; endif; ?>
    		</div>
    
        </div>
    	<?php get_sidebar(); ?>
    	<?php get_footer(); ?>

    Like I said, it works just fine for the page content, just not the blog posts. Also, I looked at the generated code and saw no post content being generated.

    Here is the address of my test server, if anyone doesn't mind taking a look: http://goatlounge.com/worldicu

    Hopefully I provided all the info people would need to figure this out. It's probably something stupid, but an extra set of eyes always helps!

    Thank you, thank you, thank you!

    Currently hating her client,
    Sara

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Client just dumped a template on me saying it was a theme only needing minor adjustments

    The ones who only want "a few simple changes" are normally the worst. I normally chill out by reading a few pages of Clientcopia just to remind myself that I Am Not Alone. ;-)

    Is the News page a Page or an archive? If it's the former, you'll need to do a bit more to get it to list posts. The easy option (if the client is using a static front page) is to set the News page as the Posts page in Admin/Settings/Reading. If you've already done that and it's still not working, you need to check your index.php template.

    Another option would to create a Page of Posts.

  3. saramw09
    Member
    Posted 4 years ago #

    Yeah, I told the guy a few minutes ago that I'm stuck on the blog page's backend, and he still wouldn't shut up about the few buttons he wants at the bottom. And more pretty colors... jeez. Next, he'll want it in "cornflower blue" to match his tie.

    So it is a blog page on a site with a static front page. It should be running off index.php instead of page.php. I deleted the page.php and have only index.php, plus the sidebar, header, and footer. Pages still show content correctly, but the blog page does not. I'm getting ready to start from scratch. -_-;

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    Can you drop a copy of your index.php file into the WordPress pastebin and post the pastebin url here?

Topic Closed

This topic has been closed to new replies.

About this Topic