WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] [closed] Page Cache URL rewriting is not working (119 posts)

  1. Well ... That gets rid of the error but doesn't explain WHY we get the error ;)

  2. iwebsource
    Member
    Posted 3 years ago #

    Hey guys,
    I am actually working with the creator of W3 Total Cache, Fredrick, who has access to my Server and will be taking a look at this. I will keep you guys posted on what he finds.

  3. bandwagon
    Member
    Posted 3 years ago #

    Ouch. This one hurt. Lost my theme late last night (I think it got rid of the css and js I was minifying). I got those back on and then, in an effort to get around the htaccess thing, rolled back to 0.9.1.3 and now I have a internal server error and a steaming pile of poo of a site. WP Minify.

  4. walidmrealtor
    Member
    Posted 3 years ago #

    I'm guessing the way twitter is buzzing about this, there will be an update soon...

  5. goddess_dix
    Member
    Posted 3 years ago #

    @polle001 - Thank you for the quick fix. I'll be looking for the update but am glad to resolve the errors in the meantime.

  6. vitalichka
    Member
    Posted 3 years ago #

    Thanks for the updates everyone.

    @simbian - Thanks for the heads up. I thought I took care of the problem with basic caching and URL rewrites off but turns out yes the site lost all CSS when logged out of Admin. I didn't test out of admin and really should have, had a brand new post with lots of traffic and it looks like everyone hit an ugly page. Wow this really sucks guys.

    As far as some of the other people saying they got rid of the error, well try logging out of Admin, don't make the same mistake I did. It looks like all errors are fixed but really are not.

    Even going to basic and disabling minify does not help. As far as .htaccess yes it simply appends it. This really sucks since I got rid of the CloudFlare plugin since this was supposed to work together so well.

    Funny thing is CloudFlare sent an email to their whole customer list stating how we no longer need their plugin and to use this one instead, I guess they didn't really test their site either.

    Thanks everyone, looking forward to an update.

    P.S. - iwebsource - please let us know as soon as you know anything.

  7. goddess_dix
    Member
    Posted 3 years ago #

    Oh geez. Yeah, I tested logged in as well. Disabled the plugin until we get a fix. Thanks again to the folks here for the heads up.

  8. robnalexpress
    Member
    Posted 3 years ago #

    FWIW, I have Rewrite URL Structure checked and I have minify mode set to manual, and both my sites are fine when logged out of admin- checked on several different browsers and computers:

    http://trianglehomesuccess.com/

    http://trianglenewhome.com/

  9. vitalichka
    Member
    Posted 3 years ago #

    polle001 - thanks for the heads up

    robnalexpress - Just checked your sites, both look right, I'm gonna try that but it seems like that would do no good in terms of actual usability you know. But thanks

    Waiting for a real fix.

  10. JustinFYI
    Member
    Posted 3 years ago #

    @iwebsource: glad Frederick's looking into it.

    Meanwhile the manual minify mode works for me. All other Cache Methods are set as "Disk".

    I'm glad I checked the forum before reverting. Google's Page Speed is rating 93/100.

  11. galic1987
    Member
    Posted 3 years ago #

    hey people , there is another bug...
    if you turn on that cloud flare system, and when u try to go to performance-> General , there is a blank screen with following errors

    Notice: Object of class stdClass could not be converted to int in /home/vhosts/galic-design.com/httpdocs/wp-content/plugins/google-sitemap-generator/sitemap.php on line 201
    Help

    Warning: require_once(/httpdocs/wp-content/plugins/w3-total-cache/lib/W3/JSON.php) [function.require-once]: failed to open stream: No such file or directory in /httpdocs/wp-content/plugins/w3-total-cache/inc/compat.php on line 21

    Fatal error: require_once() [function.require]: Failed opening required '/wp-content/plugins/w3-total-cache/lib/W3/JSON.php' (include_path='.:') in /httpdocs/wp-content/plugins/w3-total-cache/inc/compat.php on line 21

    but everything else works well on website:
    http://galic-design.com

  12. Nic Windley
    Member
    Posted 3 years ago #

    Also experiencing the same error message;

    It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess

    since the upgrade.

  13. Nic Windley
    Member
    Posted 3 years ago #

    cloudflare is working for me

  14. pull-start
    Member
    Posted 3 years ago #

    Unchecking "Rewrite URL" in Minnify settings doesn't help me. No variation of Minify-ing is working

    • I had everything set up manually, that was broken. (Unstyled content)
    • I tried auto, that didn't work.
    • I tried just minifying CSS and just minifying JS. Didn't help at all.

    With Minify off completely (in the General pane) everything else seems okay.

    Would love to have minification on, since I'm about to send out a press release and get some traffic (hopefully) that's time-sensitive.

  15. vitalichka
    Member
    Posted 3 years ago #

    I did set caching to basic and minify to manual and that did the trick but as I stated here or likely in another post, CloudFlare does not seem to accept the API key and does not save the changes made to the settings.

    Right now site looks good when logged out.

    Thanks

  16. vitalichka
    Member
    Posted 3 years ago #

    I did want to mention though, this is odd.
    When you initially go to the site Salt Lake Examiner it takes forever to load, but once loaded all other pages you may go to are very fast. Additionally, and this is very odd, the back end is extremely slow.

    Thanks

  17. vitalichka
    Member
    Posted 3 years ago #

    You know I thought this could be an issue when working on this last night.
    Seems like we are all having problems with Caching and Minify, well I don't know how many of you are on the CloudFlare network but considering that if you are you probably already have AutoMinify set up through there and this makes me wonder if that is causing a conflict since the API key does not always want to interface with the system.

    Also for example, I have my caching on the CF side set to medium but I cannot change the default of High in W3TC in WP from high to Medium, and some settings differ.

    Jut my two cents, wondering if maybe this is somehow causing a conflict then again, how many of you are on the CloudFlare CDN? No all right? And seems like basically everyone is experiencing the same problems.

    I know for me, creating a new .htaccess file definitely solves some problems because the constant appending was not a good way to proceed.

  18. vitalichka - EDIT your posts if you're posting within minutes of yourself, please :) Otherwise you're going to trigger the spam-catcher!

    I created new .htaccess and I'm not using CloudFlare

  19. Chukwudi Emmanuel Udegbunam
    Member
    Posted 3 years ago #

    @vitalichka: the link you posted before works and I kinda made it clear that W3 Total Cache's minify function just doesn't work for me thus I don't use it at all.

  20. vitalichka
    Member
    Posted 3 years ago #

    @Ipstenu - Yeah sorry about the mass posting everyone. I thought of doing that right after the last post.

    @strictlyonlinebiz - yeah you did, it wasn't the minify that wasn't working, looking through the past posts here and through the forum here you will see a trend that with the latest release there are other problems as well.

    Thanks for posting though, I did get a few good things from the article.

  21. vexite
    Member
    Posted 3 years ago #

    Version 0.9.2.1 is out now. Hopefully this will fix most if not all of the bugs introduced with 0.9.2.

  22. vitalichka
    Member
    Posted 3 years ago #

    Thanks for the heads up. Just updated, looks like CloudFlare API still not working, getting the following messages.

    At purge - Request failed. Error: Invalid zone name

    and

    When changing to medium on security in CF and saving it says "Unable to make CloudFlare API request."

    Also, when setting minify to auto, CSS is broken, had to revert to manual. But Caching enhanced seems to not throw any errors.

    What are you guys experiencing?

    ============

    UPDATE:

    Looks like the domain name under cloudflare should have been without http:// removing that helped fix the CF problem I was having.

  23. war59312
    Member
    Posted 3 years ago #

    Updated to version 0.9.2.1

    Disabled "Minify" > "Rewrite URL structure" and no more error.

    Working with "Minify mode" on "manual" and "Page Cache Method" on "Disk (enhanced)".

    Everything seems to be working now.

    PS: Also, "General" > "Miscellaneous" > "Enable Google Page Speed dashboard widget " will only enable if "Enable news dashboard widget" is also enabled.

    That should not be required.

    Ugh!

  24. simbian
    Member
    Posted 3 years ago #

    i have updated the plugin but still no luck... im the only one?

    I don't use a child theme, i use Compositio theme from Design Disease and it has one unique css.

  25. vitalichka
    Member
    Posted 3 years ago #

    Yeah everything seems to work alright with Minify set to manual and setting specific CSS files to minify.

    I did want to clarify something though. Under Page Cache > Never cache the following pages >

    it says "wp-.*.php
    index.php"

    Does this mean it will not cache anything like wp-admin? which is good but at the same time it will also not cache anything with a .php extension? Well that doesn't make much sense to me (I don't understand it) to not cache .php extensions since all of WP is PHP-based.

    Could someone shine some light on this?

    Also if someone could explain what would be good as far as settings under garbage collection intervals for the different sections, as well as updating external files.

    I'm also having a hard time understanding Browser Caching settings.

    Sorry I know this is a lot but if someone has the knowledge, you would be helping many as I am sure not everyone is sure to use this to full capacity.

    Thanks
    Vitaliy

  26. vitalichka
    Member
    Posted 3 years ago #

    @simbian - make sure to set minify to manual and tell it the URI to the CSS file. That should fix it.

  27. WebEndev
    Member
    Posted 3 years ago #

    Version 9.2.1 Not Working
    As pull-start said above:

    Unchecking "Rewrite URL" in Minnify settings doesn't help me. No variation of Minify-ing is working

    I had everything set up manually, that was broken. (Unstyled content)
    I tried auto, that didn't work.
    I tried just minifying CSS and just minifying JS. Didn't help at all.

    With Minify off completely (in the General pane) everything else seems okay.

    I'm on version 9.2.1, WP version 3.1.2 and the Genesis Framework.
    I am going to roll back a couple of versions to get it working.

  28. vitalichka
    Member
    Posted 3 years ago #

    Alright so it seems like anytime I change any of the settings under browser caching I get this error.

    Browser caching is not active. To enable it, add the following rules into the server configuration file (/server_path) of the site . Or if permission allow this can be done automatically, by clicking here:

    Even if I do auto install, it says all is okay but as soon as you save anything the same error comes up again.

    If I do browser caching of CSS and JS files suddenly it throws an error about URL rewriting and minify.

    I can't set anything under browser caching > general
    CSS and JS
    Almost nothing under HTML pages and posts
    Same applies to media and other files.

    Any help?

    Thanks

    ========
    UPDATE

    See now I disabled all browser caching and I now get this error.

    Disk enhanced page caching is not active. To enable it, add the following rules into the server configuration file

    Odd

  29. vitalichka
    Member
    Posted 3 years ago #

    @ munman - yeah I saw that but rewrite url works for me it seems. As long as minify is set to manual and I specify which CSS files I need.

  30. WebEndev
    Member
    Posted 3 years ago #

    If I disable the rewrite url it does not affect it. Still not loading my main style.css file correctly. Even though I verify the URI.
    Maybe if I disable all the other CSS files and only load style.css?

    Let me try that... back in a min

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic